Times and timezone is incorrect in some screens of Android app

There seems to be a bug in the Android app with regards to the timezone in some screens.

  • I am in Central European Time (GMT+0100).

  • Android is configured to get time and timezone information from the celluar network (no special manual setting or anything)

If I open the Ring app and press the global history button above the list of devices, times displayed are correct for my local time.

If I select my Ring Pro doorbell first, and then access its history, it indicates GMT+0000 and the wrong time.

Hmm, seems to happen if you did not enter a full address for the device location.

I think requiring a full address to be entered when you are selling a SECURITY product is ridiculous though.
I have no intention of using your location specific features, and consider it a direct security risk to provide my address to manufacturers of IoT products.
If my account gets compromised, the attacker would know both where I live, and (based on the recordings) when nobody is home.

1 Like

Make sure the “Automatic Date and Time” setting is selected on in your Android phone under Settings>General Management>Date and Time

Did you find a resolution to this? Im having the same issue. But whats weird is when i 1st installed it, it read the date and time perfectly. Now it’s off by 4hrs! I also dont have my full address for same reasoning stated before. Doesnt make sense that it’s required for the time to be correct when i have provided the area code.

To get correct time go to phone settings >general management> date and time> then enable automatic date and time.

my phone is set to automatic date and time but I’m still seeing 4 hour time difference error

1 Like

<< To get correct time go to phone settings >general management> date and time> then enable automatic date and time. >>

That does not work at all.

The only thing that fixed it for me was entering a full address.

Naturally you do not enter your own, but say the address of the authority that handles privacy complaints in your country.

1 Like

Thank you for this suggestion. Putting in the complete address worked for me. I now have the correct time on my Ring device.

1 Like