Thumbnail view on dashboard not updating

I am having the same issue. On my iPhone the thumbnail does not update when I open the app. It worked fine until a few weeks ago. I don’t want to have to go to live view. Right now it’s showing a picture from 8 minutes ago! I have the Snapshot feature on and at the most frequent since the Ring2 is hardwired. Please fix this!

1 Like

Hi. If I may offer a suggestion for resolving this issue. I also have numerous cameras on the app that would refresh within minutes, if not seconds on the Dashboard, except one which had a view that was more than 24 hours old. After following other suggestions here, with no success, I decided to power down the device by disconnecting one of the wires from the transformer that controls that doorbell and let it disconnect from the app. After a few minutes, I reconnected the wire to the transformer which repowered the Doorbell camera. The camera reconnected to the wifi in a few minutes and has been refreshing on the Dashboard, as it did previously. I hope this relieves your frustration, as it has resolved my similar issue. Good Luck.

Hi, I suspect it is a problem with the ipad app.
I have a wired doorbell and the thumbnail on the dashboard updates automatically with no problem on my Android phone (S20) but it does not automatically update on my ipad.

I’m experiencing the same issue (android app), and have been for quite a while. My floodlight cam updates the snapshot on a regular basis, but it’s hit and miss on the ring doorbell 2nd gen. The doorbell does update occasionally (on it’s own) but for the most part it’s usually a day or more behind. I’ve tried all of the suggestions mentioned by various folks in this thread but so far, the issue remains ongoing and pretty much random. It seems that many users are having the same difficulty. I really wish ring would address this!

Sorry to hear about this, neighbors! The dashboard preview image should certainly update or show, when you open the Ring app. Keep in mind, battery devices will update the dashboard image less frequently than wired-only Ring devices. When checking the dashboard, leave the Ring app open for at least 1 minute to allow time for any preview images to update.

Please trigger a motion event or perform a live view to confirm the device is online and working. See if doing so resulted in the dashboard displaying the view. The next best step will be to visit your Ring device in the Ring app and check it’s Device Settings > Video Settings to ensure “Tap Camera Preview for Live View” is toggled “on”.

If you have other Ring devices, confirm the camera preview tiles are updating for other devices on the account/ location. Remember to disable any vpn on your mobile device, if one is enabled, as well as trying to force close and reopen the Ring app.

If the above steps did not help to resolve your concern with dashboard preview images not updating, please give our support team a call at one of the numbers available here . We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.