Thumbnail view on dashboard not updating

The dashboard in ring app that has the thumbnail camera view is not updating automatically like my other 2 floodlights. Does it not update like the floodlight views? Those views say 2 seconds where the doorbell one could say yesterday’s date unless I go into the live view. Any help is appreciated. Thank you.

Interesting @sgesualdi . What doorbell do you have? Also, have you recently uninstalled and reinstalled the Ring App?

I have the ring 2. I have not installed the ring app again. The app seems ok except for that. The cameras on the other hand let’s just say have not impressed me to this point.

Interesting that this thread dried up in 2019 without an answer from support? I’m having the same issue with a Ring Video Doorbell 2 purchased a couple weeks ago. My two floodlights update within seconds of bringing up the dashboard, but my doorbell images sometimes takes hours if at all. The doorbell is wired by the way so this is not a battery problem.

The first time it got “stuck” I forced a stop on the app (android) and restarted. It still didn’t upate so I forced another stop and flushed the memory. This “appeared” to resolve the problem for a few days but other (related?) constant crashing issues propted me to remove and reinstall the app. The dashboard issue is back and no longer updating the image while the two floodlights continue working as expected in the app.

Hi @wlwhites! The displaying recent images from each of your Ring device on the dashboard of your Ring app is related to the Snapshots feature. Please ensure your Snapshot feature is enabled, as well as check the Snapshot frequency setting. If this concern persists, try removing and reinstalling the Ring app on your mobile device. I hope this helps! :slight_smile:

Thank you for your suggestion Marly_Ring. Snapshot is enabled (has been all along) and in fact set to the minimum time allowed for the doorbell, Every 5 Minutes. The doorbell is wired so no concerns about battery life with the highest frequency snapshot setting.

I mentioned in my original post that I have already removed and reinstalled the app. If the behavior continues and this is my only recourse, I’ll consider your advice of giving it another try. Unfortunately, I don’t hold much hope this will resolve my issue and currently weighing the potential temporary benefit vs. the effort/time required to reconfigure everything once the app is reinstalled. I think I may be more inclined to wait for the next update in the App Store and hope something’s changed that might improve this snapshot behavior.

This is not a Snapshot issue. I have 2 Ring Video Doorbell 3’s, front & back doors. The back door thumbnail updates automatically within seconds upon accessing the dashboard. The front door thumbnail does not. The thumbnail can be over 1 day old. It has an RSSI of -54 (better than my back door).

I have tried the Ring Chime – It is currenlty plugged into an outlet 6’ from the front door. The wall is wood frame, exactly as the back door. The back door connects via the router that is located in the basement; no issues. I have changed WiFi networks; no change.

The Snapshot feature takes photos at timed intervals whIch I definitely don’t want given the associated battery drain.

Deleting and reinstalling the iPhone Ring app sounds like a lengthy device reconnection effort. No other suggestions? Thank you!

Definitely not a snapshot setting issue. Anyone with a helpful answer cleanly to chime in here? I’m dealing with the same problem.

I am having the same issue with thumbnail on dashboard not updating. My front “doorbell 2” updates as it should. My back doorbell does not. It shows more or less a “still” picture of last motion or recording. The date is also located lower left of snapshot pic instead of the time. The date is wrong as well. I have tried everything, re-install app, door bell, internet and so forth. The RSSI value is -49. I need some help here if anybody has had this problem and resolved it. Thanks much and stay safe
I forgot to say, this camera also has a very hard time getting “live views” and picking up motions

I amHaving the same issue.

Hi there, neighbors! I wanted to update this thread with our help center article about Ring App Camera Previews. After reading through the responses here, it looks like camera previews is most likely the inquiry here.

Camera previews are still images you’ll see when you first open up the Ring app. Each should be labeled with the time since it was taken and which camera took the image. As described in the article linked above, battery-operated Video Doorbells and Camera models may not update it’s camera previews as frequently, to help save on battery life. I hope this helps! :slight_smile:

I seem to have the same problem as reported here. In particular, snapshots are being made. I can see them in the time line. However, the picture in dashboard, that used to update every 30 seconds, stopped doing so a few days ago. If someone has a clue, please tell me. As it is I can no longer see what is going on outside, making the door bell not very useful. I cannot keep turning live every 30 seconds.

I have the same exact issue. I have a 1st Gen Ring Video Doorbell, Ring Pro, Ring Floodlight Cam, and Ring Spotlight cam. About a year or 2 ago, the 1st Gen Ring stopped updating the preview completely. Now since about 2 app updates ago on iOS which was within the last week, the previews are very unreliable. Sometimes one won’t update. And it’s a shell game as to which ones will update and which ones won’t. The 1st Gen of course still has not show a preview in a year or 2 after those updates. Since you have no way of telling what firmware you have, there’s no way to troubleshoot on that front. I’ve been a Ring customer since 2015. For the most part I have enjoyed the experience, but I’ve had to return the 1st gen and pro 1 time each for replacements which work good. The floodlight has always been great and the spotlight cam works pretty good as well. I really just wish they would fix these bugs.

My app was working fine until the last 2 ring app updates. Before the ring app update, camera still pic would update every 30 seconds. Now, it only updates when I go to live view which is really annoying. My stick up cam has POE so it doesn’t have to save power. C’mon ring, take care of business!

Same here - this was working fine when I was using the free 30 days, and stopped working when I signed up for the basic plan 1 month ago (may be coincidence). Now, the Camera snapshot does not update on either my iPhone or iPad app, even though snapshots are being saved. This is a Video Doorbell 2 - mains powered, RSSI -30dbm (via a WiFi extender). Apart from this issue, everything works fine. Re-entering the App or going to a different screen and back (e.g. Settings or Live View) causes the image to be updated (once). Also the web site (account.ring.com) does not stick on one image like this - it updates correctly every minute.

Same issue here. My ring floodlight has stopped updating the thumbnail. I have power cycled it, and it solved the issue for the first few minutes but then it stopped working. The signal is decent and has remained consistent for several years. I feel like this is an issue with the device as my ring doorbell 2 (which is hardwired) does not have this issue. I wonder if when the last firmware update was? It would be nice to know when my devices are updated.

Same issue here. My wired doorbell pro has stopped refreshing.

What I have noticed is when I open the app I get an old doorbell preview image. But if I go into history and then back to the dashboard it updates itself.

It seems as though I have to navigate off of the dashboard and then back on to it to get it to refresh.

Everything was fine up until the last one or two ring updates. I’m always nervous with ring updates as I’m not sure what it will break next!

Was there ever a solution for this? I have had a Ring Doorbell 3 and a Stick Up Cam for just over 6 months and I have a screen which constantly has the Ring App up on the screen which normally updated the thumbnails every time there’s a motion. For the past 2-3 weeks the Stick Up thumbnail doesn’t update unless I manually click onto the ‘live view’ and click off it again!

Im having the same problem it use to work fine now I have to go to live view. Please fix it Im paying $100 a year for your products dont expect less

I am having the same issue here. Two cameras, one update regularly and the other one does not until I access the live view. Both cameras are hardwired, no battery issue.