This event did not record correctly - stick up cam

Lately my stick up camera has started to not record any of the movement footage. Also No live veiw available - but alerts still flood


through on notification history. Can anyone help please

Hi @Katiejfox. Try rebooting your Camera using the Ring app and also rebooting your router by unplugging it for a few seconds and plugging it back in. If that does not work, factory reset your Camera by pressing and holding the set-up button for 20–25 seconds and then reconnecting it to your wifi. Now, if you have tried all these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

Is this a Ring Stick Up Battery Cam? I had a similar issue with my Stick Up Cam battery. I have 2 stickup cam battery cameras. One is powered indoors and keeps the battery charged and the other is outdoors battery only. I swap batteries between the two when the outdoor camera battery gets low. On my outdoor camera battery only, I started getting a very short videos follow by frozen picture and then it progressed to video not recording correctly. Battery was fine. WIFI signal was strong. If I tried to view live video, it would start and immediately freeze and disconnect after about 5 seconds. I tried everything including moving it within 12 inches of my WIFI router. Nothing helped. Reset it, changed the battery, totally deleted and reinstalled it, moved it to another WIFI network in my house and nothing helped. Decided to try to hook it to my power cord for my indoor stick up and low and behold, all the problems cleared up and started working normal. I removed the power cord and it immediately started having the same issues. I pulled the battery and used a Q-Tip with alcohol and cleaned the terminals inside the camera where the battery connects as well as the terminals on the battery and it totally fixed the issue.

1 Like

Same problem here on my floodlight cam. Have rebooted camera and router, tested wi-fi, (the instructions in the app for this don’t work but managed workaround) checked signal strength, attempted hard reset, and cleaned contacts as suggested above, all to no avail. (All my other cams are working, so hard to believe it’s a Wi-Fi issue.)

Curious - did OP call support phone number/get issued solved? (I suspect support will just run me through all the same stuff, then tell me to buy another camera, but perhaps I’m wrong on that.)

(BTW it is MADDENING when Ring closes threads, causing one to have to search multiple threads or start over. Please, oh please stop doing this.)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.