"The RIng App has a Temporary Connection Issue"

I’ve been using the Ring app on my Galaxy S9, Android 9, and it’s been fine until yesterday when I would get a Temporary Connection Issue. There seemed like no way to get into the app, via cell or wifi. I’ve been using NordVpn for quite a while and have previously had no issues using the Ring app with it connected. But after disconnecting Nord today I can now get into the app. The Ring app definitely does not like Nord now for some reason… though other apps are functioning fine. Why is this a problem for the Ring App? Please fix…


This just stated happening in the last 3-4 weeks. The problem appears to only happen when wifi is enabled on my S10 phone. Takes approximately 17 seconds to open to camera views and appears to be downloading from wifi as shown on the phone wifi icon. Works perfect when wifi turned off. One to two seconds to load and open. Data saver is off. Airplane mode off. Wifi calling off. NFC off. Mobile data on. 2G, Bluetooth and Network Diagnostics on/off, no effect. Carrier is ATT but app works fine on my wife’s iPhone S6 with or without wifi on/off.

OS kernal version 4.14.117-17369568 Android version 10 Ring version 3.21.1

1 Like

Hey @ronenpet! Excellent work isolating the vpn as a cause. Check out our help center article about other android apps that can conflict with the Ring app. Try updating the Ring app or even the vpn app to see if this improves the functionality when both are enabled/ open. I hope this helps! :slight_smile:

@coinoprus , I’ve moved your post here as your concern looks closely related to this. You both also provide some great steps to improve operation. Check out my response for some additional steps, and let us know how it goes! :slight_smile:

Looks like whatever was causing the problem has been resolved. Ring app now opening within 1 second. I saw a notice from Ring stating problem with loading had been fixed and assume that was either the fix or related because everything started working properly again at that time.

Same issue now happening on iOS. Just started today. Have used NordVPN for weeks with no issue and just now get this same error. Have to turn off NordVPN to access my ring dashboard.

I have the same error on my iOS; however, I’m not using NordVPN. It was working as of 8:30 pm PST today. I’m wondering what the issue is.

This just started 4/15/20 pm EDT. Can find no info re: ring system status – anyone know what this error message actually means?

I’ve got the same issue as of today (15th April) too.


I’m having the same issue

1 Like

Same. On two different phones (two different users) for same location, on cellular and wifi.

Same issue here w an IPhone — no ither apps running.

Well, we’re not alone! Unable to chat (chat not avail) & sounds like ring having staff shortage issues (COVID ripple effect). Wonder if this is Known Issue. Have not been able to find a downrightnow equivalent for checking ring system status. Anyone know how to check sys status?

It’s now come back on.

1 Like

This just appeared on community page

Hi neighbors, I’m sorry to hear you were unable to log into the Ring app. Rest assured, our team has investigated this and it looks like it should be resolved currently. You can always keep up to date on the status of Ring here: status.ring.com. Please let us know if there’s anything we can assist with in the meantime! :slight_smile:

Update as of 7/21/2020:

In the event that you are unable to use the Ring app and you are in need of immediate assistance, please do not hesitate to give our support team a call directly at one of the numbers available here. As we are a neighbor to neighbor forum, you will need to give our team a call for this direct support. We appreciate your patience while we are looking into this.

1 Like

same issues, i just installed and it was working for a bit, then drove to work and trying to access using my iphone and got The RIng App has a Temporary Connection Issue" when openning the Ring app

1 Like

Thx! Would be helpful to receive notifications from ring when such issues arise. Is this possible? (System status issues notifications.) Glad today’s issue resolved.


Hey neighbors! Thank you for sharing what you’ve done to address this concern and get your app back up and running. Some neighbors experienced the Ring app logged them out, so you may need to force close your app or restart your phone and relaunch the app. Otherwise, all should be well.

@Ltringdoorbell Thank you for your feedback on this! I will make sure to pass this onto the appropriate team to see if we can have a notification way for our neighbors in the future. For example of what we have now, we did have an in-app prompt when you open the Ring app, letting you know it has a connection issue, but a push notification would be a great addition! :slight_smile:

could you please help with this issues as well?