Stuck updating - white blink for about a minute, blue blink for about 30 seconds, repeats

I went through the set up and when it gets to the updating firmware step, it never finishes. The device blinks white for about a minute, appears to reboot (all lights go off for about 3 seconds, charge indicator shows for about 2 seconds, then it starts blinking blue for about 10-20 seconds before repeating the whole process and never ends(

I tried doing a factory reset, deleting and reinstalling the device, and also factory reset and using the re-connect device - same result.

Im experiencing the same issue. Left it overnight and it never stopped.

Hey neighbors! In the event that your device is stuck in updating, please try the reset of the device by pressing and holding the setup button for 30 seconds. If the reset fails and the light pattern shown is still for the device updating, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.