Stuck in update (new gen 2)

I have set up a brand new gen 2 ring doorbell today and it set up perfectly. Then it started to flash white and appeared to go into update mode. I check online to see how long it takes and it says around 5 mins but could be up to 15. Mine was updating for well over an hour. I have tried a couple of resets, removing device then adding it again - however each time it is reconnected it goes into update mode again. Any ideas?


Mine has been doing the same… got mine today just the same was working fine then went in update and been like that for 3 hpurs

I’m so glad it isn’t just me - I’ve tried all sorts even resetting but it still goes to update. Feeling frustrated!

Yeah am frustrated too as I only got it today so should not be any wrong with it at all. Going to leave it over night and ring customer service tomorrow. Hopefully they will be able to do something

I’ve been using ring for 4yrs and I’ve never experienced anything like this before.
Suddenly It can’t connect wifi so I reset it. Then i tried to reinstall as a new, but It’s been updating for 3 hours now. I tried to reset about 10times but still same. Please help me!!!

It’s exactly the same as me. What the heck is this?When I called, I just got a ridiculous answer telling me to wait for a few hours.

Hi neighbors! Can you please confirm which model of Ring Doorbell you have? The name of your Doorbell can be found on the original packaging, on the back of the Doorbell itself, and on the Device Health page in the Ring app. Here are a few troubleshooting steps you can try if your Doorbell is stuck updating:

  • Disconnect the Doorbell from power for at least 1 minute and then reconnect it to power. If your Doorbell has a removable battery, make sure to remove the battery and ensure it’s fully charged as well.
  • Reset your Doorbell by holding down the setup button for at least 20 seconds. Once this reset is done, try setting the Doorbell back up in the Ring app using the steps under Set Up a Device.

Let me know if either of these steps help with your Doorbell completing its firmware update. Otherwise, please let me know which model of Doorbell you have so I can share this information with my team. You can also contact our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Mine arrived today, I’m having the exact same issue.
Did anyone elses eventually update?
I followed the instructions, and the mount is now screwed to my doorframe, so I can’t exactly return it.

mines doing the same its a floodlight wired plus installed yesterday all was fine woke up today and its stuck on installing an update, have done all the steps above with no luck

Hi there
My doorbell is second generation model 5UMSES. I have tried resetting multiple times and it doesn’t work. You mention disconnecting battery from what I can see the battery is now integral to the doorbell and cannot be removed.
It is in 100% power and I have checked my Wi-Fi and positioned it close by. I have spent a lot of money for something that o ly worked for about twenty minutes :frowning: any other ideas please.
Kind Regards
Anna (uk)

Having been left for over 12 hours it was still updating, I just did a fourth reset, and it started updating immediately again, and presto! it completed in about 5 mins. I suspect there was an issue at Ring’s end which is now resolved. Hope this worked for everyone else!
Note: I am using the Ring app on my iPhone, and restarting the app didn’t clear the ‘Updating’ status, but restarting my iPhone did.

1 Like

mines working now left it off overnight and added it again this morning and its working maybe it was a bug on Ring’s end.

1 Like

Mine has been stuck in this update since Thursday still no answers or no help from support

Hi neighbors! I’m glad to hear some of you were able to get your Ring device updated. If your Ring device is still stuck performing an update and is not responsive to the troubleshooting steps I suggested in my previous reply, please follow up with our support team so they can investigate this further. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. Feel free to report back in this thread on what solution our support team provides, as it may help other neighbors experiencing this same concern. :slight_smile:

Mine is also stuck in the endless installing and update loop. It happened to me three weeks ago on my older device so I bought a new one, guess what same problem. It’s a brand new 2020 release doorbell and it’s clear this is a systemic problem.

Ring - pls stop pretending this is an isolated issue, it’s not. Pls provide a proper fix.

1 Like

Hi, I have just set my doorbell 2nd gen up and also have white flashing light and my app telling me it’s updating and should take up to 15 mins. Well 2 and a half hours later still no progress. Spoke to customer support only to be told to wait 24hrs and if it’s still the same then ring them back. Did you get yours to work in the end? If so how? Thanks

Hi @user28477. If you have not done so already, please try the troubleshooting steps in the marked solution. If those don’t work and your Doorbell is still unable to complete the update, please follow up with our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Have the same issue for about 2 weeks now. Keeps going into update status. I followed the instructions here and it didn’t work. I called customer support this morning and spent over an hour going over fixes. Their solution was to purchase a new device, as mine is out of warranty. My device is just over 2 years old.

Sorry Ring, but I’m not buying a new device. If you can’t fix this non-isolated problem, I’ll go elsewhere. I shouldn’t have to buy a new device that is only two years old.

1 Like