Stuck in Set Up Loop With Stick Up Cam PoE / Crashing

Hello all,

When trying to set up my ring camera I get stuck in a set-up loop or the app crashes.
I’ve tried to set it up multiple times on 4 different phones. I’ve tried it with POE, USB power, Ethernet setup and also wifi setup. Everything fails.
Please let me know how to solve this issue or if there are any workarounds.


Device 1 (my phone):
iPhone 7, iOS 14.
App version is the latest because I uninstalled and reinstalled it multiple times.

On device 1, the app gets stuck in a loop between asking if the light is flashing blue and then also asking to go to WiFi settings.
Please see the pics below. Clicking yes on pic 1 will navigate you to pic 2. But then pick 2 does not give you time to leave and go to wifi settings, it automatically jumps back to pic 1. Click yes again and then this is where the loops start. Even leaving the app and checking wifi settings I can see it’s connected to the ring camera’s setup wifi.


Device 2 (spare phone):
Teracube, Android 10
App version is the latest because I just installed it to test.

On device 2, we get to the screen where the phone is connecting to the ring wifi. I click connect, and after a few seconds the app goes grey and we get a system notification saying the ring app keeps closing.


Device 3 (friend’s phone):
iPhone 7, iOS 14.
App version is the latest because we installed it to test.

Same issue as device 1.


Device 4 (2nd friend’s phone):
Samsung. Android 8 (Android version might be off, I don’t remember)
App version is the latest because we installed it to test.

Same issue as device 2.

Hi @Alcides. Thank you for taking the time to list out what you’re experiencing with the setup process on your different devices. At this point, I would definitely recommend contacting our support team so they can look into this further for you and help find a solution. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Hi @Caitlyn_Ring,
The chat option does not seem to be working. After clicking launch chat nothing happens.

Is there an email contact you can send to me in a DM?

@Alcides We don’t have email support available at this time, but you can use one of the phone numbers listed in the link I sent in my previous reply. They’ll be able to help with more in-depth troubleshooting than we can here, as they’re able to pull up your account in order to take a closer look. :slight_smile: