Strange iOS app behavior (Android comparison included)

We use the Ring app on an iPhone 6 and an LG V20 Android. They used to present the same interface to the user, now the iOS App looks very different when we accept notifications to watch an event or when looking at past recorded events. I’ve attempted to upload a side-by-side comparison of screenshots: iPhone left, Android right

The main page on app start look the same on both devices. The problem occurs with watching the Live Stream or clips on the iPhone.

I’ve tried uninstalling and reinstalling the iOS app and re-entering the user credentials. That did not solve the problem.

Hey @RN1. I can see with the screenshot on Android and iPhone that the Android side is showing the Event History Timeline. Are you sure you have the Event History Timeline enabled for the iOS device? You can check it under the Account settings in the Main Menu in the Ring app. Please ensure this is on, and to access the Event History Timeline view from the iOS device will be by tapping on the Camera Tile Preview from the Dashboard for the device, as well as clicking on Live View at any time from the Device’s Profile.


Interesting. The setting was checked/enabled. I unchecked it and rechecked it and after that the problems was fixed. Now the iOS and Android UIs match and the iPhone shows Live and archived events.

Thank you for the help.

Whoops. Spoke too soon. The app worked briefly with the new interface. Then we got another notification of an event. Checked it on the iPhone and we’re back to the older interface.

Toggled the setting again and the new interface came back.

How can we get this fixed without manually toggling the setting?

@RN1 Thank you for following up with me accordingly! It is odd that it’s working as a very hit or miss thing after activating it. What is the iOS version that your wife is running? If possible, could you take a screen recording of this happening? A recording on her phone that shows you going in, enabling the feature, showing it’s working, then closing out the app, triggering a notification, and then showing that it’s no longer in that view can help out a lot! In addition, if easier, feel free to capture a screen recording on what it looks like when going to a notification and not seeing the Timeline, as this may help clear up the concern further! :slight_smile:

Hi, it is an iPhone 6s running iOS 13.4.1. App Store says we have v 5.27.1 of the Ring App.

For various reasons it is hard for us to trigger the device, we have to wait for the camera to trigger.

Is there a way to completely uninstall the app and any associated files and then reinstall it?

@RN1 Thanks for getting back to me! You can indeed remove the Ring app from her phone, delete it from the iCloud backup (anything saved it removed when removed from iCloud backup) and then restart the phone. Once the phone turns on again, you should be able to download it and it will clear out any background saved data. Although, a good callout, as I also have a iPhone 6s, but I’m currently running iOS 13.5. I recommend having your wife update her iOS after removing the app completely, but before downloading the app again. Let me know how this goes! :slight_smile: