Stickup camera stopped working

I installed a new stick up. Completed setup. Everything worked live view and notifications.
The next day, neither the live view or notifications are working. Restarted Wi-Fi. Did everything with my phone and online I could. I can see device status and Wi-Fi signal strength to be good. But no live view or motion detection. Any help??

Have you selected disarm in the home mode by mistake as this will stop all video etc but will still show device health as good

Hi, I’ve changed the battery and the light won’t come on even after the hard reset. The red lights inside the camera turn on fine. Appreciate any suggestion.

No I havent. I have other device too, ring doorbell and I am able to pull live feed and motion detection for it

I have exactly the same problem. Indoor cam will not work on live view and will not go into setup mode. All my other cameras are working fine. I have moved it next to my wifi router so wifi is not a problem.

No it says that it’s offline.

I am having the same problem and the reset button does not reset it. Did you find a solution to your problem?

Have a spotlight battery cam, charged the battery multiple times *green light comes on*, I then insert to set up and it says low battery (2%)…tried reinstalling app, removing cam and setting up new device…same response, will not let me connect to wifi, tried both battery slots also…have a ring doorbell that works fine on wifi (got both together and both had been fine)…I did let them both die (batteries), but have done before also …any ideas?

Thanks for you help none of it worked. I bought a new one and it connected no trouble. I wish there was someone at ring to ask as there was before. Now I need to see where I can send the old one to see if they ca. Fix it any ideas?

Hi neighbors! Can you please confirm which Stick Up Camera you have? We’ll send this over to the team for review in the meantime :slight_smile:


I have the same problem - camera stopped working, bought new batteries. No joy. It will not reboot/turn on. Red lights flashing in battery ports with fully charge batteries. Please help.

Sorry to hear about this @KBlake! Trying with new and fully charged batteries was a great step to take. If you have not already, try holding the setup button for 20 seconds to perform a reset on the Cam. If this does not result in the Camera entering setup mode or completing a setup, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I have the same problem. My stick up camera stopped reading the battery. Put 3 separate fully charged batteries in it and it will not do anything. says it is offline due to dead battery. I called 3 different times for help, talked to 3 different people. The last one I talked to said he would talk to the team and I would get a email in a few days. that was about 10 days ago, nothing. Getting fustrated with this camera. I have another stick up camera and the door bell both work fine. Need a fix or a refund, dont want to take a chance on new camera especially a lighted camera.

I’m having the same exact issue. My stickup battery cam has stopped working! I installed it last weekend, the battery is at 97%, the wifi signal is good and at 7pm yesterday it stopped detecting all motion and cannot be activated into live feed. Has there been a solution that works? I have the ring doorbell and spotlight cam too, both which are working as expected. I’m hoping there is a solution and that this won’t happen frequently…what’s the use of having security cams if they’re not going to be reliable?

Have been trying to reconnect my spotlight camera for over a month and all I get is wrong password and I know password is correct as I checked it on netgear app and also login to another divide and it worked. Camera has a problem something wrong with it.

Hi @Glendar! Great job checking the wifi password to ensure it is accurate. Please ensure the password is for the 2.4 Ghz wifi frequency as this is what your Camera will try to connect to. Sometimes unique settings or characters in a wifi configuration can throw things off. Try enabling a guest network on your router with a simple SSID and password and see if your device will connect to that. If this concern persists, check out our ports and protocols article to see if it may help with obtaining connection. :slight_smile:

Try but unit will not connect. Like I said I have 3 other units and they all work with the WiFi password just this one does not . Has to be the unit went bad.

1 Like