Stickup Cam Firmware Constantly Updating

I’ve bought a second Stickup Cam Battery to add to the alarm system.

Since setting it up and adding it the app and alarm, it appears to be stuck showing the ‘firmware update’ sequence of flashing lights on the front. The cam is in the app but not accessible. It has drained through two full charges of the battery and still won’t stop the firmware update flashing.

I’ve tried resetting the cam and removing from the app/system and it’s just done the same thing again.

Any ideas? Anyone had similar? Or is it simply duff hardware that needs replacing (as I suspect here!).

Hi @TheTranter. Have you tried resetting the Camera by holding down the setup button for at least 20 seconds? If not, please give this a try, and then set it back up in the Ring App by following the steps under Set Up a Device. If that doesn’t resolve this, please give our support team a call at one of the numbers available here. They’ll be able to take a deeper look at this concern for you and get it taken care of. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: