Stick-Up Cams and Mesh Wifi

I have a Ring Doorbell with 3 Chimes and 3 Stick-Up Cameras. I use a BT Whole Home Mesh wifi system with 5 nodes. Being a mesh system, the nodes all have the same SSID and password.

My problem is that the Ring devices obstinately and persistently insist on connecting to more distant nodes with weaker wifi signals, in preference to using stronger signals from nodes that are closer.

I often get Device Health showing devices with Poor Wifi Signal, and find that they are not logged on to the nodes that would provide a much stronger signal.

Any ideas?

Hey @NigelGBR. Have you attempted to try to have the Ring devices manually connect to the nodes? While they have the same SSID and password, if you turn off certain nodes when trying to reconnect the Ring device, this may help ensure that it is getting its connection from the right node.

You will need to go one Ring device at a time, but you can turn off the other nodes temporarily, leaving just the one node that you wish to connect it to on. Then go into the Ring app > Main Menu > Devices > Ring device > Change or Reconnect to Wifi network, and then walk through the setup. You will be connecting to the same wifi network, but then you can check and ensure the node you wanted it to connect to is getting the proper connection. If this works, you can then do the same with all the other nodes/Ring devices in the home.

You can also turn off the auto routing that most mesh systems tend to do, as this could be why the nodes are constantly changing which are connected to which Ring device. If you have a way with your ISP to do this, I recommend reaching out to them to find a better way to do this kind of controlling from the node’s mesh system. Feel free to share if this works out or any other solution you find!

Thank you for the advice Chelsea_Ring. I had already partly implemented what you suggest but, for reasons that will become obvious, it could never really be a full solution. The problem devices are 2 StickUp Cams in an outdoor aviary, keeping an eye on an elderly tawny owl. The aviary is at the far end of a chain of wifi mesh devices, where I intended the cams to connect to Mesh Disc 5. Mesh Disc 5 is connected via Disc 3 or 4 depending on how the mesh configures itself. Unfortunately the cams had a habit of connecting to the weak signal from Discs 3 or 4, instead of the strong signal from Disc 5. I had switched off Disc 3 without the mesh collapsing, and that did partly alleviate the problem, but the cams still did sometimes connect to Disc 4. I am sure you can see where this is going now - if I turned off Disc 4 as well as Disc 3, then Disc 5 no longer had anything to connect to, and neither did the StickUp cams!

I have now had to do what I wanted to avoid, and run an ethernet cable out to the aviary. It had to run up through a ceiling, through a loft, out through the eaves, and overhead to the aviary. It then connects to a repurposed router reconfigured as a wired access point with a different SSID. The cameras have been permanently connected to this SSID, and are off the mesh system. I was hoping that the wifi mesh system would have saved me all that trouble, as I am far too old to be crawling around in lofts, but a proper wire is always the best solution.

I had to implement a similar ethernet run to the other end of the house when I found that power-line networking caused terrible interference on my guitar amplifiers. Sometimes the magic of clever tech works, and sometimes it doesn’t. Thanks again for your help.

1 Like

I really hope Ring will solve this problem soon - my Doorbell connects to the main router in the mesh that is located on the bottom floor instead of the one located like 5 meters away on the top floor and I cant turn the main router off (to force it to select the right one) because then the secondary router stops working as well…

This problem becomes EVEN more annoying as the doorbells seem to have quite week antennas requiring them to have really strong signal and if they dont connect to the best router this is really hard to achieve…

Any tips or updates from Ring on when this problem will be fixed would be fantastic…

Hi @MagnusHuddinge. If the above mentioned steps that were suggested didn’t offer any improvement, I would suggest reaching out to our support team. They will be able to work with you in real time to be able to diagnose and remedy this concern. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.