Stick Up Cameras Simply Just Not Working.

I bought 2 Stick Up Battery Cams the other day & they’ve not worked properly since installing.

I am having massive issues in getting a live view from them. This works once for 2 minutes then not again for hours. Rebooting my wifi mesh system seems to allow me to connect to them very briefly, but if I exit and come back into the app - I cannot connect again.

The network is fine. My internal firewall is disabled for the purposes of testing the cameras & this has made no difference whatsoever. The wifi signal across my home is perfectly fine, I’m getting RSSI 75 & 71 on each camera respectively - the cameras are located in positions close to the wifi mesh units I have placed around my home.

I have reset the cameras multiple times & tried the app on Android, iOS and Windows - there is no difference whatever device is used.

The cameras are also not recording motion properly when sensitivity is at its highest. I can literally go outside and jump/wave in front of the cameras & nothing happens.

I will not be recommending Ring to anyone & will be giving it 1 week to reach a solution here before returning the units for a refund. Absolutely terrible devices. I’ve had £20 Chinese IP cameras perform more reliably than these things.

I’d appreciate some sort of assistance regarding this & as I can see the stock answer is to check ports and protocols when I’ve seen this issue reported elsewhere on the forum, please read earlier in post where I have advised that the firewall is disabled currently.

We have started noticing this issue as well when there has been people in our driveway and the camera is not recording. We have solar powered and it will record and when there is extended motion in the driveway, it is not recording.

Hi @watsee. Thank you for reaching out to the Community and detailing your experience with both of your cameras. After going over the details, I applaud you for already being self sufficient and making some adjustments to your router to all the Ring devices to connect without errors in setup! Since you noted your RSSI values, it seems like this is where the concern lies, as an RSSI value above -70 is very poor.

You can learn more about RSSI value and what they mean in our Community post here, as well as how to improve the RSSI value in our more in-depth Help Center Article here. The following article will give you a lot of tips and tricks to help improve the wifi signal to your devices. It seems that since your RSSI value is so high, there may more devices in the home that are demanding the connection over the newly installed Stick Up Cams! In addition, this would be why your camera is missing motion events. Let me know what you take from the more in-depth troubleshooting article detailing how to troubleshoot your wifi with this concern, and I’m happy to follow up accordingly for you!

@cparman What is the RSSI for your device? What does your Live View look like? You may need to adjust the placement of your device for it to capture this movement. Lastly, feel free to detail how your motion settings are, and I’m happy to follow up with you on this. :slight_smile:

Neighbors, I want to also leave a note for you that as we are a neighbor to neighbor support forum, if you are exhausting multiple troubleshooting steps and to no avail, you may want to reach out to our support team directly. They can help isolate the concern you are having while having more in-depth information on your device and how it’s functioning. If you need this immediate support, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.


There are serveral people reporting this over the last week.

I’m not sure if Ring Community support link issues together but I think it would be best to call Ring support as they can escalate to advanced technical team / engineering team.

I have the same issue and they’ve ordered a replacement. Not sure if this will help as it’s a brand new device and numerous people are reporting the issue.