Stick up camera elite POE no longer powering up

I purchased a new Ring camera. After installing the stick up cam elite POE it worked as expected for 4 days then stopped.

I’ve tried repowering by disconnecting the Ethernet and reconnecting and holding the orange botton twice.

A steady blue light appear on the front for around 15 seconds then stops - and no further activity occurs.

Any suggestions please?

Hi @user30624. You have tried the basic troubleshooting steps I would have recommended for your concern; the next best step would be to give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

Hi, I’ve been through the support steps. I’ve also:

  1. swapped out the Ethernet cables with new ones
  2. Tried an alternative PoE and different ports.

The blue light on the front of the camera is on - steady - but still no connection.

Ever get resolved? Similar issues with my elite POE. Worked for a few days now it won’t connect and keeps power cycling. Have done hard reset, tried different cables and different POE router all the sameZ.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.