Stick Up Camera (Battery) disconnects at 45%

Right I’m not a happy camper. I bought the Ring Stick Up Camera, everything was going good, then I noticed that when the camera got to about 41% it lost connection. Done all the usual, reboots then I said sure I will just put a fully charged battery in, that worked, but then I check back 2hrs later and that battery is at 45% and the camera is disconnected. I bought a second stick up camera before discovering this problem. Any clues what to do?

Hi @Lookin4More. The battery shouldn’t drain that quickly, and the Camera shouldn’t be disconnected with a battery level of 45%. What lights did you see on the battery itself after fully charging it? It does take about 8 hours to fully charge the battery, and you’ll see a green and orange LED lit up while it’s charging. Once the battery is fully charged, you’ll see only the green LED lit up to indicate that it has finished charging.

After putting the fully charged battery into the Stick Up Cam, try resetting it fully by holding down the setup button for at least 20 seconds. Then you’ll want to set it back up in the Ring App by following the steps under Set Up a Device. This should make sure everything is working properly for you. If not, please give our support team a call at one of the numbers available here. They can take a closer look at this concern for you. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: