Stick up cam wired Ethernet configuration failing

I have a 2nd gen wired camera powered up via poe from a ubiquity switch. (My entire network is ubiquity based, aka the switch, the router, the access points). It will not successfully configure for running on Ethernet - which baffles me since that should be just dhcp. The wireless configuration setup works fine - and going that route the camera is running the latest software. I don’t want to waste my wireless bandwidth and especially since Ethernet is running out to it (the poe) - how do I convince this thing to use the Ethernet ???

thanks !

Hi @lancerus! You are correct in stating that the Ethernet should be connecting more efficiently than even wifi, as it is designed to do so. The best first steps to take here would be to test the physical ports, try plugging into other ports, and even testing another Ethernet cable. As your Cam is now connected via wifi, try removing and reinstalling the app on your mobile device. Once reinstalled, login and visit the device health section of the Ring app. There, you will see an option to change network. This should allow you to prompt the PoE connection, which should be successful as long as your router/ switch is capable of both network and power delivery. I hope this helps! :slight_smile:

I figured it out. The stick up cam and my ubiquiti poe smart switch do not get along. The switch, by default, has spanning tree protocol (STP) enabled. The ring camera blocks this. In order to get the Ethernet connection to work (in addition to poe which was already proven successful) I had to disable STP for this port in the switch. The negative of doing so is from the switch view I cannot “see” what device is connected to this port, what IP address was assigned and the MAC address. STP helps provide all of that. I was also surprised the connection was 100M and not GigE.

anyway - it’s working - ultimate root cause is the hardware (Ethernet chip?) in the ring camera which doesn’t play nice with smart switches.

1 Like

Thanks for the update @lancerus . Please don’t hesitate to reach out with any other questions!

I am running into the same problem. I’ve seen a couple posts on Reddit as well about disabling spanning tree. In my situation, I’m plugging the doorbell elite into the Ring POE adapter it came with and then straight into an ethernet port on my modem provided by CenturyLink. The modem is a Zyxel 3000Z modem. I don’t see any option to disable spanning tree in my modem’s configuration settings. Any help?

One more setting that helped me with my Araknis POE switch, after disabling spanning tree protocol (STP) on the ports for my cameras I would still have intermittent success connecting them during setup. The final trick was to force each port to 100Mbps Full Duplex instead of Auto. It seems the Ring Stick Up cam wired 2nd Gen has an issue performing the auto-negotiation of port speeds and the switch kept dropping the port. Now it connects every time no issues.