Stick Up Cam will not connect network

Please bear with my long-winded explanation of the background of this issue. Outdoor Stick UP cam battery died several days ago. Recharged and re-installed battery yesterday. Then went to Ring android app to Live View check camera alignment. I’ve been through this drill several times with no issues. This time around the Stick Up cam will not connect to wifi. Wifi signal strength and password are both good (neither has changed) and I can see that the cam does briefly connect to my router but then disconnects when the cam/app reports that the connect operation failed. Firmware router was last updated three years ago…so nothing changed in my router. Everything else connected wirelessly to the router (11 devices in all) continue to function correctly as they always have. I’m having a similar issue with a wifi-enabled Roomba that I tried to connect two days ago…it will not connect. This morning I tried connecting the cam through a cell phone hotspot…SUCCESS…but no love at all when trying to change wifi back to my network through the app. The last part of the background is that my WISP had a tower get lightning struck last weekend resulting in some damage that they fixed on Monday. So here’s where I think I am with this. Seems like something may have changed on the WISP’s network configuration that is now blocking some of the ports used by Ring and Roomba. Does that sound like a reasonable possibility?

Thanks

Hi @user12945. You could be on the right track in thinking that some part of the network configuration may have changed when the tower was damaged in a storm. You can find the ports and protocols used by Ring devices in our Help Center Article here, which may be a good place to start. If everything looks good on that front but your Ring Camera and Roomba still don’t connect, you may need to follow up with your internet service provider to see if anything has changed that may be impacting your device’s ability to connect to your wifi network.