Stick Up Cam Elite - Stuck in setup loop

Hi all,

I’ve got an issue with one of my Ring Stick Up Elite camera’s.
I have had it for a short while now and it has been brilliant, but recently, all of a sudden it just went offline. We checked connectivity, it is plugged in via POE, nothing.

This is where the fun starts. I contacted support to figure out how to troubleshoot, they have been excellent, and went through all the steps, trying to reset, unsuccessfully. The device is stuck in a loop, where you initiate the reset, after a while it enters setup mode, you run through the app to establish a connection and it fails to connect via the local wifi prompt. We have tried everything together, but that is where it fails. Repeatedly.

I have tried different power options, both PoE and USB. No difference.
I have tried holding the orange button 30+ seconds to reset it. No difference
I have tried with a different POE switches, and different ethernet cables. No difference.
I have tried with multiple mobile devices (iPhones, iPads and even a Samsung Galaxy). No difference.

The blue light just stays blue and after a while the voice is saying "Welcome to ring. Follow the instructions in the ring app to continue” and after a little while it reboots and it goes around the same way again. I can never get it to the actual setup mode.

I have tried all the above with the help of the support team, and then continued on my own.
The support team have agreed there is an issue with the camera, and they kindly have RMA’d it to replace.

The real issue is that there are not any available Stick Up Cam Elite’s in stock to replace. So I’m back to trying to troubleshoot the problem device.

I’ve seen there are individuals here with exactly the same issue I’ve had - my question is, has anyone actually managed to fix this yet? It seems a hard reset either isn’t possible, or doesn’t fully clear the memory. Has anyone managed to manually update the firmware on a device that is causing issues such as above? I’m fairly sure that is the cause, a miss-installed automatic firmware update - and no amount of running loops in setup mode is going to resolve this - it needs a wipe and restart.

Thanks all.

Did you ever get a resolution to this? I have the same problem all my setup is PoE. I noticed a camera outside offline, brought it in reset it and could not get it working on PoE spoke to Ring the issued a return for a replacement. However they have no stock don’t know when they will get stock and it is up to me to call to check if they have stock so they can ship a replacement! That was 2 or 3 months ago. Not good. I also have another Ring Stick up cam Elite. which I setup last year but didn’t deploy. I have just today 2nd June 2023 tried to configure this on PoE and couldn’t! I moved on to another Ring Stickup cam Elite that I bought off Ebay (Spoke to seller about deregistering etc). I have just tried setting that up on Ethernet and couldn’t. Finally I got the original faulty one reset and had another go at setting it up with PoE, no joy. However, I then went to all three cameras left them powered by my PoE ethernet hub and set them up as Wi-Fi not ethernet and they are all working. One of them had a software update and then carried on all are showing in my dashboard.
I have a couple of questions; can I move them over to ethernet without going through the setup process? Also looking at the label on the rear of the camera they are called Ring Stick up Camera Wired. However, I know them as Elite. What is the difference. I’m tempted to call Ring support but not convinced i’ll get a meaningful helpfull answer!
Thought I would put something out here to see if anyone can shed some light on this and hopefully a work around or solution.

Regards, Tony

Hi @Griz. If your three Stick Up Cam Elites are failing to connect via POE, I strongly advise working with our support team to further investigate. If you have called in about it before, you should be able to escalate your concern to our advanced technical support team. As for being able to change the way the Camera is connected to your network without going through the setup process, you cannot do so. You have to go through the setup process to change them over to an Ethernet connection. You can do so by going to your Camera’s Device Health and selecting Change Network. You can also do the same thing by just setting it up as a new device, which does not require you to remove your Camera from your account. Also, there is no physical difference between the Stick Up Cam Wired and Stick Up Cam Elite, as both have an Ethernet port. The Elite came with a PoE adapter (with power supply), and the Wired did not come with these accessories. The Stick Up Cam Wired is no longer sold on