Stick up cam blue light stays on

Hi,

I bought a pair of the latest gen stick up cams (battery version). I received them today and started setting them up. The first cam out of the box had a very simple setup, no issues. The second cam is not working after setup though. Here’s what happens:

  1. Battery at 100%

  2. Follow setup prompts in the Ring app to add a new device.

  3. Inserted the battery, device powers on and enters setup mode

  4. App disconnects my wifi, connects to cam wifi, adds home Wifi to cam, brings me back to home wifi.

  5. Setup continues “rome wasn’t build in a day”…

  6. App arrives at a firmware update screen saying it may take up to 5 minutes to complete

  7. Cam blue led blinks, then remains on for 2 seconds then blinks again over and over.

  8. After about 5 mins the cam blue LED finally turns off, app is back at the Ring app home screen. I can see a preview of my first cam but the trouble cam shows a black box with an image of the stick up cam on it and an icon on the bottom right stating the camera is updating

  9. 10 minutes later, no activity from the trouble cam, the cam preview on the Ring app still shows the same as above

  10. Tried to connect to live view, never connects

  11. Checked device settings and viewed device health. Info indicates that the cam firmware is up to date.

  12. Another 10 minutes later the preview screen no longer has the updating icon on it. I try going to live view but I can never connect.

I’ve tried the above about 6 times now without any luck by removing the camera and pressing the setup button for 15 seconds and starting the whole process again. The first camera was so easy!

Do I have a dud?

1 Like

Hey @Mariozzz. Major props to you for outlining the process in detail of what you have done, as well as the troubleshooting. At this time, I recommend reaching out to our support team for advanced troubleshooting to get this sorted out for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let us know how this goes, as the steps you take after and the outcome may help other neighbors that stumble upon this thread! :slight_smile:

1 Like

Did they help you get it fixed? Mine is having a similar issue.

Did they help you get it fixed? I’m having the same issue.

I’m having the same problem. Blue light stays on. Also motion only works when you’re standing directly in front of it. This is too many to be an isolated case. Someone needs to look into this. Please help us

I covered my blue light with duct tape. Wondering WHY does it have to stay on? What’s its purpose? The duct tape is not affecting the sound, motion alerts or the picture so that is a fix for me. The blue light brings to much attention to the camera. I don’t need it messed with.