Stick Up Cam 2nd Gen won't install on Netgear AC1750

I have a 2nd Gen Stick Up Cam that will not complete the setup process with my Netgear AC1750 Router. It will complete the process with a different router. I currently have three 1st Gen Stick Up Cams & a Ring Alarm system attached to the Netgear, so am at a loss. I did work with tech support about 2 weeks ago who decided the camera must be defective, so they sent me a replacement (also a 2nd Gen). Same problem as the first camera. Has anyone run into a similar problem? It seems to get stuck at the “Rome wasn’t built in a day” notice, then the camera starts blinking GREEN or sometimes RED. I have tried installing with both my Android phone and an iPad. Same issue. Likewise if I install to a different router (which is successful) and then change network to the Netgear (which won’t complete). Thoughts?

Hey @glp. I know you were previously working with support, but have you had a chance to follow up with them on this? Since the replacement doesn’t seem to mesh well with your router but can connect to a different network, it’s definitely worth getting in touch with support again. They can escalate this to our advanced support team who can look into more of your network settings, as there may be something there that needs to be adjusted to allow this 2nd Gen Stick Up Cam to connect.

Thanks for the reply. I will be calling support tomorrow.

1 Like

Exact. Same. Problem. I’m a new user and am very frustrated.

Tried to install doorbell with same issues. Googled the hell out of it. Did every change to modem settings, phone settings, etc I could find. Nothing works. Spent literally two hours on it. No go and I don’t have access to a different modem/router during the pandemic. I’m pretty ticked-not a great way to start out as a new customer. Definitely not plug and play in any sense of the word.

I wanted the doorbell primarilary but decided to get the security system in case I want monitoring later. Bummed that the only thing that doesn’t work is the doorbell and now I’ll have to sit on the phone and go over everything I did for how long before they figure out what’s wrong? Like I have time for all of this. Grrrrrr.

After many hours of trying to resolve the issue with my Ring stickup (returning the camera, getting a new camera, updating my router bios, etc), I finally resolved the problem by replacing my Netgear router with a TP-Link router. All of my Ring devices have communicated happily since.

2 Likes

I just bought both the modem/router and the Ring system since I just bought my house. I wish Ring would just state they aren’t compatible with NetGear. Would have saved me hours of trying to find a solution. Do you have Comcast? Looking for a suggestion of a modem/router combo that works with both Ring and Comcast. Thanks.