Spotlight connectivity is infuriating. Won't find networks

Sorry for the long post, but I"m at wit’s end and could use some help.

My battery spotlight camera stopped communicating when the batteries. got low The health check said it was still connected, but it wasn’t transmitting any updates. I recharged the batteries and restarted, but the app still showed low batteries and wasn’t updating. So I tried the following:

  1. Pulled the batteies and restarted. Red light inside showed the batteries are charged, but no connection

  2. Walked through connection set-up again by pressing button on top, etc. got the purple/white light saying it couldn’t connect to my wifi network (network is fine)

  3. Brought it inside next to the route, just in case. Still can’t connect. Made sure phone cellular was turned off (per help files), rebooted my phone/app, etc.

  4. Removed the camera from the app, did a factory reset of the camera thinking I would just start over. After connecting to the “ring network” on my phone, app would not find any Wifi network (even as I was sitting next to it).

  5. Tried deleting and re-installing the app. Reset my router, etc. Still, the camera won’t connect to my network even if I “forget” it an re-enter the password.

I am 5 minutes from throwing this into the dumpster. Sitting on my desk it detects motion and turns on the floodlight, but I can’t get it connected to my app. It’s like it’s not seeing any wifi networks, which might explain why it could not reconnect. What’s even worse is that I can’t get help from Ring/Amazon. They send me to useless instructions and I can’t talk to anyone.

Any other suggestions before I run over this repeatedly with my car?

I was able to get it connected, but no idea why this worked. Maybe this will help someone else.

I went into my router settings and created a new guest SSID (password protected) and it attached just fine. However, it will still not connect to my regular 2.4ghz network. This makes no sense whatsoever, but here we are.

Sorry to hear about this experience @sdmike! A Ring device setup is intended to be quick and easy, but there are times where network variables can factor in connection. Glad to see you got it connected, and thank you very much for sharing your solution for other neighbors to see.

Depending on security type, network type, SSID name/ characters, and other uncommon network features, a guest network can sometimes help as it is often standard compared to a custom setup. With that being said, most default routers should allow a setup with no roadblocks. Just in case, here is also our help center article on ports! :slight_smile:

I’m not letting Ring off the hook on this one. While I’m glad I got it fixed, there’s no reason this should have happened. This unit was connected to my 2.4ghz home WIFI network for a year. After the battery replacement it would not log into that same network, acting like the password was bad. In fact, once I reset the unit to factory and walked through the “new camera” process, it would fail to find ANY network during that step in the setup. I work with computers all day, every day, and it shouldn’t take someone who knows networking and troubleshooting as well as I do to make a consumer product work.

I am so with you. Curse the day I bought this entire freaking system. Stayed working fine for a couple of weeks…now NOTHING