Spotlight Camera Mount - Freezes every couple hours

Hardwire installation

  • Worked fine for a couple hours, then app stated that it didn’t have a connection

  • Froze with spolights on (probably 12 hours until I noticed)

  • Initially thought it wasn’t connecting due to bad WIFI connection. Moved an access point closer to it’s location. Still no connection.

  • Contacted support on Amazon, they had me reboot it. i.e. I flipped the breaker.

  • Still frozen

  • Restarted again

  • Worked!

  • However, I am having to restart it every couple hours. Did I get a bad unit?

Hi @bobbis27. Thanks for providing insight on what steps you’ve taken so far. Would you mind following up with our support team from here? You’ve tried the basic steps so far, and our support team will be able to take a deeper look into this for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: