Spotlight camera doesn't recognize the battery

My spotlight camera won’t recognize that the battery is inserted. Under device health it will say, require battery. The battery is in the right way and fully charged. Camera works ( picture not in full color) but I can’t tell what battery life is left. Help!! I have taken the battery out and re-inserted it multiple times, but nothing. Had this camera less than a month now. Anyone else had this problem before?

Hi @Cwhite ! Can you please let us know if you have 1 or 2 batteries inserted in your Spotlight Cam. If only 1, can you please tell us which slot it is in (left or right if you’re looking at the device)? Also, is the battery charged to 100%? Thanks!

1 battery and I tried both slots. Yes, fully charged. I took camera off my account and wanted to re-set up from the start and nothing would work anymore. No flashing light, etc.
I am getting a replacement camera

I am having a similar issue, I think. My camera doesn’t seem to work when I use one of my batteries. When I check the device health, (when I noticed the problem, it said battery was 78% charged) everything seems good. Charged battery and good wifi connection. But I can’t view live feed and it won’t pick up any motion.

I am having the exact same issue. Won’t recognize the fully charged battery in either slot. Anyone find a solution?

Hey neighbors! We have been noticing some of our neighbors reporting on this concern, and have a few things you can try to get it up and running. At this time, if your Spotlight Camera will not reconnect or complete a setup, please attempt the following:

  • Ensure both of your batteries are fully charged (if you have two), or has been charging for several hours.
  • Ensure there is no debris in the battery hatch and that the hatch is closed.
  • Press the setup button on the Cam and complete the setup in the Ring app.
  • If lights flash and setup is not completing in the app, please remove and reinstall the Ring app on your mobile device, disable VPN, and have your wifi router close to your Camera.
  • If lights do not indicate setup mode on the Spotlight Cam, or setup is not completing, perform a reset on the Camera by holding the setup button for 20 seconds.

If the above steps do not result in successful setup or operation, please reach out to our support team by phone for more in-depth assistance.

My spotlight camera does not recognize full batteries and won’t turn on. I have tried to delete the device and add it again and have done a hard reset…still nothing. Feeling frustrated.

Hey @Timavila. Are you able to reach out to our support team, as recommended if the troubleshooting steps given are to no avail for you? If you have not, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I am having the same problem. Two fully charged batteries and device says both are dead.

I’m having the same problem. I have one unit that works witht he same charged battery but the other same unit doesn’t work, so I’m wondering if it’s the unit rather than the battery? I purchased another battery but the issue continues in both battery slots. Do you know if there is a guarantee with Ring or a quick fix for this problem?

I had this issue with mine as well. I had to take the battery out and shove it up there again. This time I really heard it click! Came back in and gave it a couple minutes and then it showed up.

Call them. Camera has 1 year warranty. I had to mail 2 back do far. Very frustrating

Same problem. Worked fine until battery finally depleted in the spotlight cam. Replaced the battery with a freshly charged backup battery and unit (and app) show the battery is dead. I recharged both batteries overnight and inserted both batteries into the unit. The unit only recognizes one of the batteries and says it is dead. Doesn’t even recognize the other battery. I’ll try the suggested solutions, but am frustrated. System has worked fine for 1 year.

I am having the same problem. Battery does not show charged. I can put the battery in other devices and it works fine. My unit is approaching 2 years so out of warranty.

Thanks to all who responded to me. I did several things: reloaded the app, rebooted my router, and made sure I was on the right WiFi network, all with the help of customer support; don’t know which did the trick but now my system is working!

1 Like

So if I delete the app & reinstall, I’ll have to reset the other Ring devices (doorbell, etc) all over again? Pain in the A. Can we get a reason this is happening to so many customers?

I have tried all of the solutions you have mentioned. My spotlight camera flashes blue/white. I’ve reset it. I’ve deleted and reinstalled app. I’ve deleted the camera from the app. I’ve reset the camera. I cannot get the camera to recognize two full batteries.

The camera has worked well for 12 months. The battery died in the camera before I replaced it. Now, when I put in a fresh/full battery (or two) the unit does not recognize that the batteries are charged.

Why are so many of us having the same problem??

I have two batteries, both fully charged, and my camera won’t recognize the second battery when installed. Any ideas are appreciated.

Hello, I experienced the same issue. When I recharged my 2 batteries for our home spotlight camera and replaced them in the device, the start up light at the bottom did not light up. I cleaned the inside of device with an air can, dry cloth and cleaned the batteries but this also did not work. I went onto my account to remove the device and to reinstall it, but that also was unsucessful. I tried every suggested troubleshoot but did not have luck. I did call ring and learned that I had the protection plan that covers a repalcement. So I recommend you check if you have this same warranty.

1 Like

Similar problem where one interface shows it sees two batteries and another that says I need to add a battery.