Spotlight Camera Battery

For some time one of my Ring Spotlight Battery Cameras only intermittently “acknowledges” on the app on my phone that it has a second fully charged battery on standby. Instead it “says” add a battery. I have tried different batteries in the camera to no avail. Sometimes it shows 2 batteries in place, but is currently warning that one battery needs charging and is “ignoring” the second fully charged battery already in place. I have deleted the Ring app, logged on and off and hard reset my iPhone. Nothing works. Help. Julie

Hey there Jules54,
It would appear that only you and I have equipment that isn’t sensed as ‘installed’, judging from absolutely No Mention in Ring Troubleshooting info. Have you received any info re: battery not installed message when it actually is installed as displayed by the Red Light below the battery slot of the spotlight cam? I have the additional problem of seeing icons representing both left and right batteries but the device health dialogue indicates ‘No battery present’ then without touching the spotlight cam, fifteen minutes later the ‘No Battery’ message has been replaced by the numerical level of charge. Then hours later the ‘No battery installed’ message returns. My four units all seem to have issues with recognizing the Battery Door is opened when it is closed. I can’t decide if the issue is a hardware or software problem. What has been your experience?

Hi KB1

I also have the experience of the No Battery present message, then shortly afterwards the numerical level of charge shows a battery being present. Then a short time later the no battery present message reappears. However I am only experiencing this on 1 of my 3 cameras.

I reported this to Ring Help line earlier this year. They couldn’t determine what was happening either. They checked the health etc from their end and they could tell I had 2 batteries in the camera, even tho my camera was reporting only one installed. They eventually recommended resetting the camera as a new device.

This fixed the problem for a month or so but the same problem has reoccurred.

Like you I also experience the “door not shut” message on the same camera, when it clearly is shut. I have found logging on and off the Ring app usually resolves this.

As I am only experiencing these issues on one camera I am assuming it may be a hardware-related problem.

Hi @Jules54 Thanks for this information. As mentioned, it may be best to reach out to our support to take a look at the ‘door’ being open. That is definitely not expected behavior. Thanks!


Hi again KB1

After a weekend with my camera flicking between full battery and charge/add a battery I gave in and called the Ring help line. After some discussion the following was suggested. Hold the top button on the camera lid for 20 seconds. Then reconnect the camera to my WiFi network as a new device. I will try this later today. If this doesn’t work (and as I have tried everything else suggested over several months), my camera will be replaced as it is still under warranty. I thought you might like to try the top button option as well.