Spotlight Cam stopped working

My mom installed a Ring spotlight cam on her house two days ago. It setup fine, everything was great.
Today, it says it’s disconnected. These are the steps I tried:
I charged the battery again, to make sure it was full.
I pressed the button. The light did not flash.
I pressed and held the button for 20 seconds, the light did not flash.
I took the battery out and put it in again.

Any advice? It’s not responding to anything.

Sorry to hear about this, @kclommen! It definitely sounds like the Spotlight Camera is not powering up, as a reset and setup attempt did not result in light indicators. When pressing the setup button, as you know, the bottom should flash and the Camera will likely announce setup mode audibly.

As you’ve already charged the battery completely, please also check the battery hatch for any debris as well as ensure the hatch is closed securely. If the Spotlight Cam still does not respond to setup mode, and a setup will not complete in the Ring app, the best next step will be to reach out to our support team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I have the same problem, Spotlight Cam stopped working. We had a power failure and when the power was restored several of our Ring devices would no longer connect. I was able to fix all but one of the Spotlight Cams. I took the batteries out and charged them overnight. I reinstalled the batteries, but it will not turn on. If I press the button on the top nothing happens. If I do the 20 second cold restart, nothing happens. The spot light does not blink at all. If I open the battery compartment, there is a red light next to each of the batteries. If I pull one or both, the corresponding lights go out, and go back on when I re-insert the batteries.

Hi @dss0427. It certainly looks like you’ve covered all the best steps to resolve this. Thank you for taking the time to resolve this. If the Camera is still unresponsive despite a reset and fully charged batteries, please check the battery compartment for any debris. Please also ensure the battery hatch is closed securely, and that the Camera did not reconnect or communicate within the Ring app.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile:

1 Like

Thanks for the reply. I verified that the red light next to each battery was lit. I also tried using a 3rd battery that was also charged overnight. I called the support line and was talked through essentially the same steps. Ring is sending a replacement.

1 Like