Spotlight Cam setup fail showing green blinking

Last two years ago we bought 2 Spotlight Cam Solar and it works so well with our fairly decent the same company internet provider in a different area. Setup is flawless and got no problem afterwards of anything.

Recently we just bought another Spotlight Cam Solar for our new office location with the same company internet provider but it’s located remotely. I tried to set it up but guess what it fails multiple times showing blinking green after it stucks around 95% setup. I already tried this method:

  1. Tried to reset the Spotlight Cam by holding 20s.
  2. Tried to reset the Spotlight Cam by holding 30s.
  3. Tried to unplug the router for 20s, 30s and 40s.
  4. Tried to use static DNS when connecting to Wi-Fi
  5. Rebooted my phone thrice.
  6. Cleared cache and data of ring app, and log-in.
  7. Tried to turn on and start setting up the Spotlight Cam with 2 batteries installed (I also did tried it with solar connected to it).
  8. Waited for few hours with 2 batteries installed before setting up.
  9. Tried to fully reset the router.
  10. Tried to put the Spotlight Cam beside the router.
  11. Tried to set it up using another device.

All of that still fails and still showing green blinks and stucks 95% setup in the app. And yes, after 95% the setup ask me what color should I choose for the light, then afterwards, it redirects me to set it up again lol.

Internet connection performance is quitely good, tried to test it with some various internet speed tester and it produce good performance. So it should not be the problem cuz it’s the same internet provider and it also uses the same router.

But when I tried to set it up in our house, it succeeded flawlessly. It doesn’t stuck around 95% and it doesn’t blinks green multiple times.

I really don’t know what is the problem with this, and I know what is the meaning of blinking green light, but I’m confused, what do you mean that the router got a problem that is stated in the papers?

Is there any fix in this problem?
I saw the other topic here stated the same problem with this, they said it’s already fixed and solved, but looks like it is not for some, including us. Please don’t reply me with the same solution that I already did above.

Hi @firemax13. It could be that your office WiFi has different security standards than your home WiFi. For this, you may need to contact your ISP to have the adjust the settings to allow your Cam to connect. If there are special characters in your password, this may also cause an issue. Here are the Ports and Protocols Ring devices use. These may need to be adjusted to allow the Ring device to connect. Since it connects in one place, and not the other, this leads me to believe it is a security protocol issue. Let me know what your ISP advises.

1 Like

@Tom_Ring Thank you! This is also what I suspected after days of searching of solutions. I suspected that the internet security in remote area is different in the urban area here. I will try to follow the link you sent and will try to modify our router setting and our internet setting, and will report the result.

I will also try to contact our ISP regarding with this matter.

1 Like

Hi @firemax13. No problem! This can also happen with different makes/models of routers. If you are unable to solve this, feel free to send us a private message on Facebook @Ring for assistance.

1 Like

@Tom_Ring Thank you so much for the assist and for the info regarding about changing ports and contacting the ISP.

The issue we fought was the internet DNS server, ISP did setted the our router with weird DNS server, causing the spotlight camera failed to connect and even other wireless camera brand also failed. Even me can’t browse other website which is accessible when I’m on data mode lol.

We tried to use recommended DNS but still it won’t connect, and then we did tried to test all DNS server out there and successfully setted up the spotlight camera using the cloudflare DNS.

It was a small spot of mistakes that the ISP technician did that cost us few weeks of puzzle HAHA.

And now we are happy to say that the problem was totally solved. Thank you so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.