Spotlight cam pro battery plugged in but says in battery mode

Another moderator on another post said it was fixed on the backend however it is still not working for me. I called support yesterday and they aren’t sure if maybe the issue now is with 3rd party adapters like the ones I am using so they are sending me a Ring adapter to try. I had not problem for months with the 3rd party adapters so clearly this is a software issue. I’m hoping it’s not a ploy to force customer to used their own branded adapters because I refuse to do that.

Hi @Mark_CT. This thread is for the Spotlight Cam Battery, while the thread you are referring to is regarding the Stick Up Cam. These are different devices, so the reply in the thread for the Stick Up Cam does not apply here. We do not have an update on the issue affecting the Spotlight Cam Battery at this time, and encourage neighbors to contact our support team if they have not already done so.

Same problem here. Bought this spotlight cam plus plug in version in Nov…installed in Feb and it worked for a few hours and is saying it’s in battery mode even though it’s plugged into the wall outlet. I’ve gone thru multiple troubleshooting sessions with support, including multiple factory resets. One agent told me I was missing batteries and was adamant that there should be batteries included with this plug-in camera…even though the instructions don’t mention anything about batteries. Finally got transferred to 2nd level support and they are asking that I ship this unit back to them. I guess I will have to live without my security camera for a while longer. Very disappointing for such an expensive camera.

Wow. I thought it was just me. Ring Stick Up Cam user here, just saw my cam (with constant power & battery installed) was complaining of battery mode only. Have tested the outlet and the power supply and both are good & working. Camera is stuck now in battery mode only. Need a fix! Out here in California, USA.

I had this same issue. I was using a USB 3.0 power supply to a USB-C cable. I switched the power supply to an actual USB-C output and it finally powered on and worked properly even without the battery installed.

I’m thinking this issue is mostly caused by insufficient power supplies.

Thanks for that info. Interesting since my 3rd party adapters were working great for 3 months and the batteries we always at 100%. Since the stick up cams have a barrel connector, there isn’t a 3rd party cable that has USB-C end and an adapter that would work with it currently. It’s disappointing that Ring changed their software and left many customers with this issue.