Spotlight cam pro battery plugged in but says in battery mode

I am having the exact problem with the spotlight cam plus plug in that was bought in December of 22. I installed in April 23 and it worked fine for 12 hours before going offline and telling me it is in battery mode. However, when i try to change the mode it is in wired mode. I called support and the said it must have a battery even though it is plug in, makes no sence. Also I was told if it goes offline without a battery the only way to get it back is to reset it manually which means going up a ladder. Now I can’t even get it to reset manually until I put a battery in it. Support was no help at all, I wish I didn’t buy it. Has anyone had any help finding a solution?

Hi all,
I have the same issue as everyone else here with the Spot Light Cam Pro. In the settings it shows as wired, on the Dashboard it shows as Battery mode exactly how the screenshots above are showing.

If I switch it back to battery mode, it immediately pops up saying that this camera is plugged in and would I like to switch it to wired mode.

Definitely a firmware/software bug if it is this wide spread. Reaching out to support results in the same response as above - reset/change modes/reboot and like everyone else here. It doesn’t work.

Short of refunding the camera and cancelling my Ring Protect Plus plan, can the support team here at least confirm the Ring team are looking in to this bug? @Caitlyn_Ring (give me some hope to stick with the ring infrastructure before I move on).

Hi @user42767. Yes, rest assured that our team is investigating and working to resolve the issue as soon as possible.

1 Like

Add me to the list of customers with 2 Pro cameras connected to USB-C power that are stuck in battery mode. Exact same behavior as others here have shared. Battery stays at 100% so I know the USB power is correct. I have rebooted and switched between battery and wired mode multiple times.

I expect Ring to have a firmware fix soon. Very disappointing for how expensive the cameras are.

1 Like

I have the same issue, please do a fix!! It should be simple… if it shows “wired” in device settings, no need for the device to be in battery mode! See that was simple!!

And other. Based in the UK. I’ve already had one replacement and now the second is doing the same after 2-3 weeks. It’s a joke. What a waste of money. The only way I’ve been able to find anything like a solution is to remove the device and reinstall. Complete waste of time.

Add me to the list. Was on the phone with support for a while. They sent me a new camera. Same problem. Just ordered another hardwired adapter from amazon. Not optimistic.

Same issue in Toronto, Canada. Have a plug in plus camera and after a week, it automatically went into battery mode and now its stuck. We’ve tried resetting the device, removing and reinstalling. Husband has had to go up the ladder numerous times. We’re frustrated and feel lost. How is there absolutely no updates or guidance from the ring support team other than “we are working on it”. By now we should have a notice and some additional info/ actions! At this point its just a camera for show. Neighbour had car stolen a week ago, would be nice to have footage and be vigilant in protecting our own home. If no update after another week we are switching. Not impressed at how this is being managed at all.

:wave: add me to the list. My spotlight camera plus has been up less than two weeks and I cannot connect to the camera. When looking in device settings it states battery mode. When looking in general settings it states wired. Cannot find any support for the USB - C type power supply. Please resolve this.

Having the same issue. I double checked that the wired unit is getting power but WILL NOT go into wired mode. Tried rebooting several times and nothing.
If they can’t fix this soon I’ll just return it.

Hi - I have the exact same issue with a Stick-Up Cam 3rd Gen…I have it outside pointing to the parking lot of my building at Apartment complex. It has a battery in it and also plugged into a power adapter. The battery’s inside as backup in case somebody cuts the wire! Anyway, it’s always worked…until it doesn’t and I’ve been highly annoyed because I don’t get the live preview from it on my notifications like I do with all my other cameras. I don’t know what’s up with that. So on the settings it says it’s on wired mode but on the dashboard, it says battery mode because it’s not plugged in, but is IS plugged in. I know it’s getting AC adapter power because it’s basically constantly recording and the battery stays at 100% all day. I have tried rebooting it from the app, when that didn’t work, I tried deactivation and removing it then setting it up again (so it deleted all my videos for nothing because it didn’t work). I reset it again and installed it in battery mode, then tried to switch it to wired but but it says it’s not plugged in but it is or the battery wouldn’t stay at 100% all the time…I’m going to call in tomorrow but based on all these replies, I’m NOT hopeful either…:frowning:

1 Like

Exactly the same problem here in Germany. Tried every suggestion. Support was not helpful either. Waiting for a solution!

1 Like

Hey Neighbors. Thank you for voicing your concern on this issue. We are aware that there is a problem with some Cams and their power status. Our support team is working closely with our engineers to investigate and resolve this concern. At this time, the best approach is to contact our support team so a support ticket can be created. Once a resolution is found, you should be notified by email, or you can check back on this thread to see if a Moderator has updated the solution. Thank you for your patience.

Add me to this as well. Caused an argument with my husband as i blamed him for faulty installation and now i find this thread and have to go apologize. I’ll be checking back for a solution.

Add me to the list. Same issue. Saw the same concern posted few months ago. Hope is a little luxury here.

My spot light cam is having issue with “in battery mode even being plugged in an outlet”. Currently having no solution per ring support team. In the mean time just winder if the battery will be charged if I leave it in the camera and still plug the camera in an outlet so I wont have to worry about the annoying battery charging process?

Same problem here. I bought the wired spotlight cam so I would not have to recharge batteries. The fist time around It all started well, then after less than a week of being connected it just stopped working, the device wanted to switch to battery mode, saying there was “no power connected” to the device, since there was no battery installed, the it just would not work at all.

I received a brand new replacement (very quickly I might add, thank you), I also bought a set of back up batteries.
I installed the camera with the wired option, but also installed the batteries, just in case! Again, less than a week of having it re-installed it does not seem to “see” the wired connection, getting the message that the device has “automatically switched to battery power” and the setting are optimized to “extend battery life”. It is wired!

It sounds like a software issue at this point.

Rebooting the device does nothing, re-installing only works for a few days and then the problem shows up again.

Hopefully this is resolved soon, it looks like the problem has existed for a few months by now.

1 Like

Join the club. So annoying that Ring has been so slow in resolving this and other issues.

1 Like

I downloaded the new app update today but it didn’t fix this problem. Unbelievable.

@Tom_Ring and other moderators. Is there an update on this issue on whether its resolved. I was just about buying 8-10 spotlight cam plus with wiring kit and found this issue. Im not doing that until this issue is resolved. Might have to switch to different brand if Ring is dragging their feet on this.