Spotlight cam pro battery plugged in but says in battery mode

I have spot light cam pro battery that is now plugged in. Both batteries at 100% and charged. Bought 02/2023 rssi at 50 asks me I’m plugged in and would I like to switch to wired mode. I successfully switched to wired mode. Then it shows message that I’m not plugged in but in battery mode until I plugg in

1 Like

Hi @jjq57. Check to ensure the power adapter is firmly plugged in both on the Camera and at the power outlet. Then try rebooting your Spotlight Cam in the Ring app using the steps outlined here. This should only take a few moments. Let me know if you’re able to utilize Wired Mode after these steps.

Follow procedure Twice still says not plugged
When I switch back to battery it shows this message


I am also having the same issue from Feb 25 onwards. Have you been able to resolve this issue.

If everything appears to be plugged in correctly, and a reboot did not resolve this concern, I’d recommend following up with our support team at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support. You can also contact our support team on Facebook or Twitter by sending a private or direct message @Ring.

same issue, did you solve this?

I have the same issue. I reset the plug and it’s working now. However, it won’t let me to to live feed. It just stuck in the low-battery warning. It also said I have 2 batteries, when it’s a plug-in, no battery. What is the solution? I even reinstalled it but still have the same problem.

Hi neighbors. If you have tried the troubleshooting steps mentioned in the previous comments and are still having the same concern, the next best step would be to contact our support team for further assistance.

Hi. I am having the same problem that users jjq57, skshak, JamieP and LadyIDO are. I spent 45 minutes on a phone call with customer service yesterday with someone who is not a native speaker of English and they could not understand what I was describing as the problem. They kept telling me things like reboot the device, which I have done multiple times, press the button on top of the camera to reconnect the device to wifi, which I have done multiple times. They told me to switch the device settings → general settings → power mode from “battery” to “wired”. It was in wired mode. I had previously switched it from battery mode to wired and back multiple times. When I plug the device into a wall outlet, it pops up the message telling me the device is now wired. So then I switched it to wired mode. Then it told me I had successfully changed to wired mode.
But then, when I go to the device settings to turn the light brightness up to the max allowed under wired mode, or when I try to set the snapshot feature to 3 minutes, 1 minute, or 30 seconds, it will not let me because the device thinks it is in battery mode. And it defaults back to 1 snapshot per hour. and you can not adjust the snapshot feature to once every 30 minute or once every 5 minutes, that battery mode allows, because the application control is only showing the wired mode choices of 30 seconds, 1 minute or 3 minutes. I tried to embed multiple screen captures here, but the forum sent me an error telling me that new users can only embed 1 image.

I would also like to point out that I have 2 “spotlight cam plus” cameras and when I plug them in to wall power, they switch over to wired mode correctly and allow me to take snapshots every 30 seconds and turn the light brightness up to the wired mode level, instead of the lower battery mode level.

Do you guys have a fix for the “spotlight cam pro” model? If not, how do I get a refund for this defective product?

I have the device plugged into a 110v wall outlet. The device correctly identifies that it is plugged in.
But then when you change it over to “wired mode”, the device is then identifying itself as either running on a solar plug in or on battery. Again, this problem only happens on my spotlight pro.

You can see the camera battery is at 100% and the lightning bolt symbol is showing you that the battery is being charged from the plug in wire. But then the device says it is in “battery mode” even after changing it to “wired mode” under device settings → general settings → mower mode → wired. And after restarting the device in wired mode, general settings page is identifying the device as being in “wired mode”.

hey all,

recently purcahsed the " Ring Spotlight Cam Pro Wired", which turns out is just a Battery one, with the hardwired kit - sounds good so far…

however since setting up, a few of major issues.

  1. The camera wont work without the battery - even though it knows its hard-wired in?

  2. The UI states the camera is in “battery mode” even though its not?

  3. The hird wiring, doesnt charge the internal battery, you have to take it out and manually charge it - which is pointless anyway, as per point 1 and 2

I have multiple other cameras and ring products however this seems ridiclious to me and suppot team have been useless. ive callled them twice and their response is that its “working as expected” and that “its a battery powered device, so it needs a battery” - even though i clearly purcahsed the “wired” option?

Anyone else having this issue?

1 Like

Hi @JamieP. The Spotlight Cam Pro Wired should work as a hardwired device. Since your Camera is reporting it is in battery mode and not charging the battery, try the following steps:

  • Verify the USB-C connector is plugged in correctly. You can try unplugging it and plugging it back into the Camera.

  • Double-check your hardwiring installation. We recommend consulting a qualified electrician for assistance.

If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. Since you have worked with our support team before, you can escalate your concern to our advanced technical support team to further investigate. You can also reach out to our support team on Facebook by sending a private message to @Ring.

I bought the battery version of the spotlight cam pro for my backyard and the cheaper spotlight cam plus for the sides of my house since the area needed to be watched is smaller and high video quality isn’t as important. Then I later bought a power cable for the spotlight cam pro. But when it is plugged in, it prompts me to change it over to “wired” mode, but then when the set up is done, it still says “this device is in battery mode”, just like your is doing. And it is not allowing me to access the high power consumption brighter LED light settings or the faster 30sec/1min/3min snapshot settings.

BUT… when I plug in my spotlight camp PLUS, it correctly switches over to wired mode and allows to me set it for 30 second snapshots and use the brighter light settings.

Also a side note: the spotlight cam plus will work correctly with Ring (amazon) and Eeero (also amazon) brand power cords. But if you use an off-brand USB-C cable found on Amazon, it will error out and go into “battery mode”. The spotlight cam PRO will error out and go into battery mode regardless if it is wired up to a Ring power cord, Eero power cord, or an off-brand USB-C power cord.

I purchase 2 “wired” spotlight cam and like all of you revived the one with the battery and also the wired kit.

I installed the wired kit, confirmed power is going to the unit however the camera will only work on battery power and not wired. I connected a second wired unit to another hardwire to test the units and still nothing when it comes to power. It will only rub on battery power and will not use the hardwire.

Kinda fed up with this as all of my other hardwired cameras work but this.

I installed a few of these ones. Do you remember selecting “Wired” during the setup process for each of the cams? If not, then in the Ring app, go to the camera and select “Device Settings”. Then scroll down and click on “General Settings”. You should see a row that says “Power Mode” - you’ll see either “Wired” or “Battery”. If it’s "Battery, then click on that row and change it to “Wired Mode”.

1 Like

From reading lots of other comments on this forum, what I am gathering is that this bug effects only the spotlight cam pro and not the spotlight cam plus. I have also seen others comment that this bug only started to happen after a firmware update in late February 2023.

The solution to this problem would be for them to write a new firmware update that allows the user to choose “wired” or battery and then have the camera apply that setting, regardless of what the power input cable is telling the camera.

My best guess is that the camera is mis-identifying the input power cord as being a solar panel. They want you to keep the camera on “battery” if you have a solar panel, not have it set to “wired”. They need to make a new firmware update

that allows us to override the camera settings, not let the camera override our decisions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Hey neighbors, thanks for your continued feedback on this. I have merged a few similar threads into one, so it is easier to communicate any relevant updates. For any neighbors who are new to this thread, and are unable to swap their Spotlight Cam Pro to Wired Mode, please first try the steps below:

  • Check that the powder adapter is fully plugged in, or ensure the Hardwired Kit is properly installed.
  • In the Ring app navigate to the Spotlight Cam Pro > Device Settings > General Settings > Power Mode and toggle this to Wired Mode.
  • Reboot the Spotlight Cam using the reboot option on the Device Health screen.

If these steps don’t work, please follow up with our support team at one of the numbers available here. You can also get in touch with our support team on Facebook or Twitter by sending a private message @Ring. That way our team can gather examples of this issue, and review device details in order to find a resolution. I will be marking this reply as a temporary solution, so neighbors new to this thread can easily locate this information. Thank you!