Spotlight Cam Plus connected, but no recording or live view

I recently installed a 5 camera Ring system at a relative’s house consisting of 4 wired Spotlight Cam Plus and a doorbell.
This setup worked very well for a few weeks, after which 3 of the spotlight cams stopped showing video. One of them was showing offline (of the 5 cameras it was the one I thought might have signal issues over time due to placement) but the other 2 showed online with sufficient signal strength. These would also register events, however the app would say the footage was unavailable. Live view would not work (said that the camera was not connected even though it was) and light/siren triggers would not work through the app.

I revisited the site and did as much on-site troubleshooting as I could and could never get the 3 cameras in question to work, even after moving them as close to the router as I could (relatives were out of town so I couldn’t get inside). I was able to get image at one key location by moving the one spotlight model that was still working from the back of the house to the front.
The doorbell has never given an issue.

I removed the 3 cameras in question and brought them home so I could work on them on a bench and can still not get them to operate correctly.

I reset them sucessfully and remove them from the app. I can get through the setup process as well…scan the barcode, trigger setup mode with the top button and the process will finish. The cams will immediately go into update mode, but once that finishes they just stop functioning. They show connected with strong signal (router is in the same room) but no live view and no motion trigger events registering.
One of the units seems to be stuck in an update loop. It’ll update (shows in the app and via flashing light on the cam) then a while later it’s doing it again.

I can only figure the cameras are defective, but not being very experienced with Ring products I wanted to ask here. It seems that there have been a good many reports of this type of issue, but I haven’t seen a clear resolution.

Hi @canooten. Thank you for sharing details on the troubleshooting steps you’ve already taken so far. It sounds like there could be a network issue at the installation location - was the Live View also not working when you set them up on your own wifi network? What are the download and upload speeds at the installation location? Is there a specific error message you receive when you try to activate the Live View? Feel free to share any screenshots that demonstrate what you’re seeing on your end.

I’m getting the same behavior at the test location as the installation location.

Internet speeds at the install location are good - 300mbps up and down on a fiber connection. WiFi can be an issue at some areas outside the house, but I don’t see that being the issue due to one test I ran.

There was one particular location that a camera was needed - covering the front drive and garage of the house. That camera is one that went out a week or so after I installed it. My thought was WiFi coverage was not sufficient even though the camera showed connected in the app and the signal strength was adequate (-50 to -55).
As a test I placed a WiFi extender about 6’ away from the camera, inside the house and was still unable to get an image or live view. WiFi signal on the app went up to the low -40’s and I had excellent coverage on other devices at the exact same location as the camera.

As a second test, I took that camera down and swapped it with the one Spotlight cam that was still functioning at the location. That camera works fine at the same location that the other one would not work. It’s still working today, a few weeks after I did this.

The camera I took down is one I have on my test bench and I am still unable to get an image or live view. It shows connected with strong signal, but when I try live view it says it’s not connected. I get the same result with the other 2 cameras I took down.

Images are below:

First is the camera that I swapped at the driveway location. I get image and have good signal strength.

The next is the camera I took down on the test bench. This camera is about 15’ away from the wireless router, in the same room - no obstructions at all - so signal is very strong here. ‘test 2’ is the camera to look at -

Hi @canooten. I am happy to chime in. I appreciate you sharing this additional information. I would recommend looking into your router settings to make sure they are still set to work correctly with your Ring devices. If you have done this already and are still having the same concern, give our support team a call to further investigate this with you.

I am having the same issue. Everything worked just fine until I had to charge the battery. Now the camera doesnt work at all. I have tried all the trouble shooting on these threads and nothing has fixed it.

Hi @user2759275. If you’d like assistance, we need some baseline information about your device. You can start by creating a new post with the specific model device you have, along with relevant information like the devices RSSI, Ring app version and any video examples or screenshots of any errors you are getting. Thanks, neighbor.