Spotlight Cam Not Powering Up

I have two batteries fully charged. The red lights inside the cam are lit when batteries are inserted. The white outside light does not light to setup. I have tried switching batteries to each side, only using one battery and forgetting/reinstall device to no avail. I removed batteries to charge on 12/31 and reinstalled 1/1 and it worked. Noticed it offline today 1/3 and now won’t allow setup.

1 Like

I am having the same exact issue. Can’t seem to find answer to fix this problem.


If you find a fix please post and I’ll do the same. Was hoping someone would have an idea.

I contacted Ring and they advised to return to QVC where I purchased.

They tried to reset or restore it and would not work.

1 Like

Appreciate this. I am having the same issue with a Spotlight Battery Camera.

Same issue.

Hey neighbors. For devices that are not powering up and your batteries (if applicable) are fully charged, your best option is to reach out to our support team here. They will be able to help address this concern for you. :smiley_cat:

1 Like

Batteries charged fully,put in ,red lights on but no white light flashing during setup?