Spotlight cam disconnected, lights are on but won’t enter setup

I bought 2 spotlight cameras. installed by professional electricians. They worked fine for a couple of months on my Orbi mesh network. Then one went offline. The lights are on but I cannot enter into set up mode. I press the button on top and nothing happens. Press it for 20 seconds and nothing happens. it doesn’t light up. It’s obviously got power as the main lights are on but it just doesn’t seem to be working. I’ve tried rebooting routers and a witching the on and off the light switch it’s attached to. Am I looking at returning the unit?

Hi @user36964. The Spotlight Cam should definitely go into setup mode after holding down the setup button for 20 seconds, as this will complete a reset. Since the Cam is unresponsive after this reset, please follow up with our support team at one of the numbers available here. They can ensure any applicable troubleshooting has been completed and review the device’s warranty to determine the best resolution. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.