Spotlight Cam Battery 5AT3S8 Won’t Connect

Hi all, I’ve got a Spotlight Cam Battery, Model 5AT3S8 that will not connect to any WiFi network. I’ve now tried with three different Access Point types and networks with no luck.

I get through setup and the camera goes to blinking green every time.

At the office, I connect to a network using a Ubiquiti AP and then an old Linksys Wireless router. At home I am using eero.

I am able to see the camera join the wireless network but then it goes to flashing green like it’s not connected. I’ve done several “hard resets” on the camera, rebooted all of the local network hardware, and even tried to set a static IP via the Ring app in case it wasn’t pulling a DHCP address.

Since I’ve tried three different sites - I’m thinking it’s the camera with a software issue.

Is there anything else I can try that I’m not thinking of or any diagnostics I can access as the end user?

Thank you!

Hi @Jcbrannan. You’re on the right track with the troubleshooting steps you’ve tried so far. If you haven’t already, I’d recommend trying the steps below as well:

  • If you have a dual-band router, try making a guest network that is only 2.4GHz and attempt to connect the Spotlight Cam to this network.
  • Attempt a new setup of your Spotlight Cam on a different smartphone or tablet, if you have access to one.
  • Check the ports and protocols on your wifi network to ensure the ones that Ring devices use are opened.
  • Review the tips and tricks in our Help Center Article here to see if there’s any other steps you may not have tried yet.

Let me know if any of these troubleshooting steps help you successfully complete the setup with your Spotlight Cam. If not, please follow up with our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. :slight_smile: