Spotlight Cam and Eero Connectivity

For the last year, I have had a the following Ring devices connected to my in home Eero mesh network…

  • Ring alarm system
  • Doorbell Cam 2 (1ea)
  • Stick Up Cam, battery (2ea)
  • Spotlight Cam, battery (4ea)

I am awaiting delivery of two additional Spotlight Cam’s that I intend to install in my backyard. My current Ring devices have operated with my Eero network without issue since installation. In order to prepare for my new cams, I have installed an additional Eero device in my backyard shed, so as to enhance my yards wifi coverage. The Eero device is on my network and fully functional with an excellant signal.

Of the four Spotlight cams, the three that are in closest proximity to the new Eero device, show in the Eero app as being connected. Of these three, the two which are farthest away are connected and function properly (live video, motion alerts, etc). The Spotlight cam which is closest to the new Eero device, while it shows in the Eero app as being connected, will not operate as it should. I am unable to get live video, nor will it record with motion alerts, or any other functionality.

If I reboot the new Eero device, the Spotlight cam I am having issues with will connect to the next closest Eero device and pretty much immediately operate as normal. Once the new Eero device comes back online, when the problemation cam connects, it stops working. The other two Spotlight cams that connect to the new Eero device continue to function normally.

I am stumped. I have rebooted the the problematic cam, reconnected to the network but once it connects to the new Eero device, it stops fucntioning. The Eero app shows the cam as being connected, the Ring app shows the cam as having a good wifi signal, but the cam wont function.

Anyone in the community have any experience or ideas as to what is the cause and hopefully a possible solution?

Hey @cgordonn. It sounds like it may be something with the camera itself! To take a deeper look into this for you, I recommend calling up our support team for more in-depth troubleshooting with the device. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how this goes, as I would love to know the outcome of them looking more into this for you! :slight_smile:

Ever get any update on this?

It seems to me that it is a compatibility issue with newer Eero systems.

I have a new Eero 6 mesh Wi-Fi that my cameras will not connect to (Indoor Cam and Floodlight camera). Both cameras do connect to my old routers (an AT&T wifi modem/router and a NETGEAR PowerLINE WiFi 1000).

I have Even tried disabling the 5ghz band on my Eero system and it still fails to connect and claims my router is too far away even if I place my Eero 6 extender within inches of my cameras.

The odd thing is that my battery powered Video Doorbell (1st gen) has no issues connecting to the Eero6 mesh Wi-fi.

Any suggestions on how to fix this?