Sound on my Keypad was going and is now gone

Call support for a replacement. There isn’t anything you can do to fix it. It’s a blown speaker.

4 Likes

Same thing happened to me this past week. Exactly as you described.

Mine is starting to go I’m getting the garbled sound I’m afraid mine is going to go. My system isn’t a month old this is very disappointing.

Just ran into the same problem. The sounds was fuzzy and now doesn’t work. The unit is only a few months old.

Mine is doing the same thing.
Resetting it did not help.

Hey neighbors! For Keypad audio concerns, checking the volume setting in your Ring app will be the best first step. Try also unplugging the Keypad and plugging back in.

As it looks like most have attempted the above steps and more, the next best step will be to reach out to our support team.

The same exact thing happened to me. After adjusting the volume settings in the app did not help, I contacted Ring Support; we removed the device from the app, did a factory reset, and added the device back and it still did not work. Ring is sending me a replacement keypad, no charge (with Ring+, you get extended warranty with no expiration). Overall, Ring is the greatest!

1 Like

The same thing just happened to mine. I keyed in the code and it sounded garbled the first couple digits then quit making any sound. No warning. I checked the volume and i tried resetting it with no results. I have a ring security plan so I will call for a replacement. Thanks for the info everyone.

The same thing happened to mine, anyone find a fix? Other than getting a replacement? Also, how do I get a replacement?

Hi neighbors. If you have removed your Keypad from your system,factory reset it, and then re-set up the device and the sound is still gone, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Ring has set up their systems to discourage anyone from getting help.

1 Like

interesting… was thinking to report my problem here and just came across this thread. I installed my new Ring Alarm system about 2.5 months ago, and then a couple weeks ago I noticed the same sort of strange change to the sounds coming out of the keypad speaker - pretty well just how the original poster of this thread described. At the moment, although the sounds haven’t completely died, but the sounds are indeed fuzzy and distorted sometimes (seems to change randomly). Not only that, the clicking sound sometimes seems slightly different pressing different keys, which makes no sense at all…

When new, the sounds were all crisp, uniform and clear, but something has changed.

I would have thought the sounds are produced by a piezoelectric speaker, but to me it almost sounds like an old fashioned paper speaker cone that’s been damaged. If a piezo speaker, weird that it would fail so quickly/easily.

Has everyone else with this problem had the sound completely die and have to replace the keypad?

sounds like this is what’s happening to mine… i’ll try the reset but get prepared to call Ring and ask for a replacement. it’s weird because the system is only a few months old.

I have the same issue with my keypad. The sound is very fuzzy and I cannot hear any keypad presses. Only had the system for 2 months and its malfunctioning like this…what a joke!

Definately a hardware issue. When arming or in test mode with my Gen 1 keypad if I tap on the case it makes some intermitent sounds. Either wiring or speaker went bad.

just chiming in here with an update… I posted back in May2020 that my keypad (gen1) had distorted sounds after a couple months from original installation, same as the OP reported. I noticed the distortion was worse at higher volume levels, so I turned the keypad chirp volume down (in the app settings) to around 50-75% or so, and that seemed to make the keypad audio sound ok, or at least less distorted

well yesterday (now Jan 2021), the keypad suddenly stopped making any sounds at all. None of the normal audio sounds work any more - keypad clicks, verbal mode change announcements, chirps when sensors activated, etc. Changing the audio volume, or resetting the keypad doesn’t do anything to fix this. Otherwise the keypad does function normally, just without any audio feedback. Annoying

It seems the speaker/piezo has completely died. Pretty sure this is a simple hardware failure, and it seems to be a fairly common occurrence reported by many others on this forum

edit: did anyone here get a replacement keypad from Ring for this problem? and more specifically, if your original keypad was a gen1 model, were you able to get another gen1 as replacement?

Not really thrilled at the idea of getting a gen2 if that happens to be the only one Ring is now offering, since I’d have to modify my wall mount, and also I read that the gen2 no longer continuously displays the system’s mode status when permanently powered (an essential feature, IMO)

edit2:

called support and got answers to my own question above - Ring is going to send me a replacement keypad, but unfortunately gen1 keypads are no longer available so it will be a gen2 unit

1 Like

Thank you for sharing your results with the Community, @abc! This, along with your details on the process, will surely help other neighbors who might have similar questions or concerns. We are glad to hear that support was able to assist! :slight_smile:

update: Ring sent me a replacement keypad (Gen 2) and it arrived within a few days, along with return label to send back my defective gen 1.

my original Gen 1 was wall-mounted (and powered continuously via wiring hidden in the wall from my old ADT system) , but because the Gen 2 keypad is smaller I had to patch/paint a bit of a hole in the wall that my Gen 1 was conveniently covering. It’s not always an advantage to make a product smaller! :neutral_face:

That aside, I installed and activated the new keypad, and removed the old one from my system. Everything is working normally now - sounds and all.

Thanks Ring!

Let me take this opportunity to complain about 1 serious design deficiency with the newer Gen 2 keypad - it’s something already noted by many other customers and I think it’s got to be one of the top requested features, e.g. Keypad Gen2 Mode Lights

Ring: Please bring back the always-illuminated MODE lights when the keypad is constantly powered and power-save mode is off, just like the old gen 1 keypad (and just like probably 100% of every other alarm system out there).

It absolutely makes zero sense why you don’t keep LED displaying the current system mode status on when the unit is AC-powered. The gen2 keypad has otherwise made using my system WORSE than it was originally with gen1 keypad. Please fix ASAP.

1 Like

So, I’ve gone through 2 keypads (both gen 1). The audio is now gone on the second one. I’ve tried calling Customer support but each time I’m told wait time is more than 45"!!! Frustrating… Since we’ve lost the audio, we’ve tripped the alarm 3 times… very annoying! Can customer support reach out to me please? You have my log-in info…

Hi @terralav. The Ring Community is a neighbor to neighbor support forum and it is not monitored by a member of the support team. Any account specific related concerns will have to be addressed by reaching out directly to our support team, as no one in the Ring Community has access to your personal information. :slightly_smiling_face: