Solved: Ring doorbell pro - working but showing offline on app

So, I seem to be experiencing the same thing with a Ring Pro I setup for a friend several months ago. It’s a persistent problem. Is there an expected resolution or workaround? My only other choice will be to have her return the device.

This discussion has been flagged as “SOLVED”, but it is definitely not solved, I started having this same issue today as well!

This is definitely a problem. I’m experiencing the same issue and nothing else on my network is having a problem. Router hasn’t changed, password. It’s a Ring issue and they aren’t owning it.

Hi neighbors. If the post in this thread marked “Solved” didn’t provide a solution for you, try these steps. First, remove power from your Ring Pro for 3 minutes, then add the power back. Next, press and hold the setup button on the Ring Pro for 20 seconds, then release. Allow 1 minute for your Ring Pro to reboot. Lastly, reconnect your Ring Pro to wifi. You may also need to change the ports and protocols for your router.

If these suggested steps do not correct your issue, Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

The fact that I was getting motion alert notifications but not being able to view live view tells me that the wifi is connected to be able to record these motion alerts. I’ve tested ringing my own doorbell and was able to get instant alert notification. What worked for me was updating the app to the latest version. It may be Ring server updates that prevented the older app versions from working. That’s why it’s happening to us at about the same time. This is just my guest. So I recommend app update first.

I have this issue today in UK on flood light cam. Any others experiencing such ?

Having the same issue with my ring doorbell 2. Just started today. I have rebooted the router and removed the battery from the doorbell, no joy.

1 Like

Just logged out of the ting app and logged back in, it is now showing as online, but my floodlight can is showing as offline.

I did the same and it didn’t work for me.

Hi there, neighbors! As shown on, our team reported an occurrence where some devices were reporting offline incorrectly. This has since been resolved on Mar 19, at 19:21 UTC.

If this concern is persisting for you, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Thanks for the info. I rebooted my router and my Ring immediately went back online.

1 Like

Glad to hear that worked for you @Safehome51! :clap:

Happened to mine tonight, motion works, doorbell works, but app shows camera is offline. Resetting the router did nothing. Any ideas??


We have 2 Ring Pro’s in different geographic locations, both offline since yesterday (red wifi symbol). We have multiple stick-up cams, also in different locations and they are all online with no issues. This is indicative of an issue on Ring’s end, though their Service Status shows no issues. Anyone else having downtime with Ring Pro only right now?

I was having this issue with Flood LIght Cam. I restarted my router and it seems to have fixed the issue

This is getting to sound like a stuck record.

I have the same problem with one of my Indoor Cams. Snapshots are working, motion detection and recording are working. Playing these back on the apps is working. But the camera is showing offline and Live View is not available on either the Ring app or the Rapid Ring app.

Simple “Reconnecting” via the Ring app doesn’t work.

All other Ring cameras and doorbell are showing online and working fine. No change to WiFi.

Please, Ring, do proper problem solving and a root cause analysis on this fault. Cycling the device power, setting it up from scratch or rebooting WiFi may “fix” the problem, but this is NOT a solution.

In my case, and for some others on this thread (based on the symptoms we have described) it is clear that the fault is at the individual device level with it entering an indeterminate state. Possibly hardware, but more likely a firmware or software bug.

I am glad I chose Ring over the very strong, and in some aspects superior, competition, but unreliability, intermittent failures, poor audio, poor video and unacceptable lag are a huge frustration and killing our experience.

Ring could do so much better.

As an aside …
It seems that “poor WiFi signal” is the stock answer Ring Support give to most problems Ring customers have.

I don’t buy it. I can stand next to a Ring device that gives totally unusable video & audio performance and yet make a perfect video internet call on my phone using the same WiFi, the same channel, the same WiFi Access Point, the same router and modem over the same internet connection.

If our smart phones using WiFi and any of a number of apps like WhatsApp, Skype, Slack, Zoom and Teams, can do it why can’t a Ring device?

P.S. I should add that the camera was working fine up to two days ago.

1 Like

I am having this exact same issue now.

From my router, I can see the Ring Doorbell Pro is assigned an IP address, and I can ping it. It also has very good Wifi signals. All my other devices, many of which are Ring Stick-up Cameras, are all online.

And it continues to detect motion and respond to pressing the button.

There seems to be a reason bug being introduced on either the service or the firmware.

Yep, same issue here. Been doing my head in all day, changed WiFi channels, rebooted router all do nothing.

Cycle the power on the doorbell pro 2 and it comes back for about 5mins, but all doorbell presses still work etc and it’s been taking the snapshots fine.

How annoying…

I have two doorbell cams in two locations over 100 miles apart. Both show offline, but are recording motion and responding to rings. A problem is I cannot do live view on either.

Same issue. Have noticed other threads commenting on the same behavior. Using Pro 2, connected to Eero. Offline on app, but it takes snapshots, Live View won’t turn on. However, it will behave normally with motion, but then turns offline a few minutes later.