[SOLVED] Not getting any ring/motion notifications from Android app

I have freshly set up a new Ring Doorbell Wired. I am not getting any ring/motion event notifications on any of the two Android phones that I have logged into with that Ring doorbell. The two phones are completely different. One is a OnePlus 8 Pro running Android 11, the other is running Android 10 and some minor brand called Teracube. These following are the troubleshooting steps I’ve already exhausted. Can anyone help and suggest something? Much appreciated. It’s been super frustrating. :pray:t3:

  1. Yes, I have turned on the “Ring alerts”, “Motion detection”, and “Motion alerts” settings for this doorbell on both phones. And yes, I have double checked that notifications are turned on for the app at the Android system-level app settings. Here’s a screenshot for both:

  2. Yes, I have tried uninstalling and reinstalling the Ring app (on both phones).

  3. No, I’m not in “do not disturb” mode on either phone.

  4. I have also linked the doorbell to an Amazon Echo Show, and announcements+live view is working perfectly in the Echo Show. I thought perhaps there could be some chance that maybe the Echo link is interfering/intercepting the ring/motion events, with the system having considered it “answered”, and therefore deciding to not send alerts to the Android phones for that reason. Although that seemed unlikely and unreasonable to me, I still tried disconnecting the power to the Echo device. That didn’t help. I even further went ahead and unlinked the Echo device from the Ring account altogether. Still nothing (even uninstalled and reinstalled the Ring app again after disconnecting the Echo device).

  5. Yes I have already went through the troubleshooting steps on Ring’s own support page specifically for Android notifications, which only offers very basic steps anyhow.

  6. No, I don’t have any apps like Clean Master or others that are listed on this Ring support page.

  7. The only thing I haven’t done is factory reset my phones. I am not willing to do that. I mean, besides the inconvenience of a factory reset, the fact that it’s showing the same problem on two totally different phones indicates that it’s very unlikely this would fix the issue.

Someone please HELP!!

After a few frustrating hours of trying a gazillion different things to simply get notifications on my phone from the doorbell, I finally discovered the problem, which of course was none of the things I listed in my original post that I’d already tried. For the benefit of others, here’s the solution below. I think a factory reset would perhaps solve the issue too, but this solution pinpoints exactly what the factory reset would have done without actually having to do a full factory reset. After describing the solution, I’ll explain why exactly this works.

  1. If Ring app is currently installed, uninstall it first.
  2. In your Android settings, go to the “Apps” page which lists all apps on your device.
  3. Find the app called “Google Play Services”.
  4. On the settings page for that app, click on “Storage and cache” (or something similar, might be different depending on phone).
  5. Click “Clear storage”. Pay attention to the two different buttons. One is “Clear cache”. But you want to do the other one, which is “Clear storage”.
  6. This will bring up a Google-customized clear storage page which is different than the general clear storage action for all other apps. On that page, you’ll want to hit the button that says “Clear All Data” (usually the last button on the bottom of three), and then confirm the warning. Don’t worry, this does not remove your Google account or do anything drastic. The only thing it does is disable your Google account backup if you had it enabled, but a few seconds after you clear the storage, you get a notification exactly for that, saying that backup has this disabled, and by clicking on that notification you can re-enable it really easily.
  7. Finally, after clearing Google Play Services storage, reinstall the Ring app, double-check doorbell notification settings, and things should work beautifully now!

So why does this actually work? Well, I don’t know if this is a Ring bug or an Android bug, or a combination of the two, but it has to do with how Android handles push notifications. And it does so through Google Play Services. I don’t know what exactly about the state of that app prevents Ring push notifications, and why push notifications work for all other apps on my phone but not Ring, but I’m glad that at least clearing it fixes the problem! Whew. I only hope this doesn’t become a recurring issue, wherever so while later, this problem creeps up without me changing anything on my phone.