Solution found for Live View Issue over Cellular

Many have recent Live View issues on cellular. I think the 2 common protocol for streaming are, UDP port-1194 and TCP port-443. I think Ring uses UDP to send video back to the phone.
I can’t make changes to my Android 11 phone cause it is not rooted. In my phone, “Multimedia message proxy & port” are not set, and might be the ones that need to change.

I tried 2 different Android free trial VPN apps, ( no payment needed ), Hide.me & PrivateVPN, and both work, only after changing APP’s Protocol Setting to TCP. Neither would work with UDP.

T-Mobile is my cellular provider, so I think the Ring APP’s are using UDP and my provider is expecting TCP.

Tomorrow I’ll contact Ring Support to see if this is the real issue and if they have a better solution than having to use a VPN for Cellular Live View.

Update:
Contacted Ring Support, and I have to admit, It was a little difficult getting this issue to the engineers. Having worked in the industry, customer support is only focused on solving specific issues, like a camera, doorbell or a cellphone phone or provider. They are not setup to solve global issues affecting multiple organizations. Usually the engineers are the one that look for incompatibilities involving new technologies. I could be wrong, but the reports I see seemed to start with the 5G implementation about 1 year ago, with different phones and different carriers, were Live View no longer worked on Cellular, but works over ok WIFI. After being transferred to 4 different Reps, and 2 hours later, I spoke to a supervisor was able to convince him to forward this issue to his engineers.

I feel better knowing someone with the right knowledge will at least look into this issue. If they can’t or won’t provide resolution, I at least expect them to provide us with info needed to give cellphone maker or provider as to what they need to do to resolve this issue, instead of telling up to “talk to your of provider or cellphone maker”, without providing info they need. I will follow-up in a couple of weeks to see what they have discovered.

2 Likes

Update:
Use GOOGLE, and search for: “The Protocols and Ports Used by Ring Devices”. Reading this, I understand the video, (SIP-RTP) not being received by my phone using Cellular is sent using UDP protocol. Ring also send RTP to the APP, using TCP protocol. When I installed a VPN app, “Hideme”, to my Samsung A32, in APP’s setting I could change the protocol and found with VPN, video worked with TCP, but not UDP.

Since my daughter’s phone, Oneplus 8T, works over T-Mobile cellular, same locating, using 5G without a VPN, I now know the issue is not with my provider or ring, as the T-Mobile APN settings are exactly the same for both phones.

Even thou I see reports of this issue with I-phones, my issue is with my Samsung A32 phone. I’m not sure if other Samsung 5G phones have this issue, but my previous Samsung LTE/4G phones worked. Would love to know the Samsung 5G models that work or not using Cellular data.

My hopes of getting resolution from Samsung are slim, but I’ll try. I’ve added a totaly free VPN with ads, “vpnify” to use for Cellular Live View only. It doesn’t have settings to change protocol, but worked, straight out the box. I may end up replacing the phone once I know which Samsung 5G phones work.