Solid white ring, cannot setup Ring doorbell


I’ve received my Ring doorbell video PRO wired last day and tried to connect it via the app. I’ve followed all steps via the app to configure it but the Ring doesn’t show up in my wifi options on my phone.

The doorbell keeps having a darkish white solid circle and after a couple of minutes it brightens up, rotates ones, blinks a couple of times and goes back to darkish white solid circle.

I’ve tried to reset the Ring doorbell (hold the orange button on the right side for 10, 15, 30 and 60 seconds) without any results. The doorbell keeps doing the same thing.

I’ve read something about power problem so I’ve brought my doorbell including adapter to work to see if the problem is at my house with the power but it still gives the same problems.

Any idea’s on what to do? It doesn’t seem to reset nor can I continue with my setup.


To clearfy I made some pictures from the rings


Image 2


Image 3

Contacted Ring by phone and they confirmed a malfunction and they’re sending a new one. In case someone experiences the same issue, contact Ring.


Following the Video Doorbell Pro Installation Guide is always a good step, for any other neighbors experiencing this. If you have a Video Doorbell Pro 2, here is its installation guide.

For some great tips and lists on troubleshooting power, check out our Community article for hardwiring the Video Doorbell Pro.

As shared above, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Thank you for returning to share your experience, @SamS. :slight_smile:

1 Like