Solar panel stopped charging Spotlight batteries

Hi there community -

I have a Ring Spotlight camera with two batteries, connected to a Ring solar charger. In the 3+ years I’ve had my camera, I’ve had to manually charge the batteries once – until the last month. Now, it seems as though the solar panel just isn’t charging the batteries. The solar panel seems clean, there are no obvious flaws in the wiring and the connection from the solar panel wire to the camera seems secure.

The batteries are charging just fine when I remove them and plug them in.

Any reasons why the solar panel would suddenly stop working / or the charging would suddenly stop charging?

Hi @NickCPDX. When you go into your Ring app > Main Menu > Devices > Device connected to solar panel > Device Health, does it show that there is a solar panel connected? If your app is not showing the solar panel as connected under your Device Health page, you will want to ensure the device is connected properly. I recommend detaching the solar panel from your device and then attaching it back, while also ensuring that there is no dust and debris on the solar panels and at the connection.

After checking the connection, if you find that it is still not showing as connected in the Device Health section, please try resetting your Ring device (not the solar panel) by pressing and holding the setup button for 20 seconds. After this reset, re-establish the connection your device has in your Ring app by tapping on Reconnect or Change Wifi Network under Device Health. This will take you through another setup of the Ring device in the Ring app. Once completed, check the Device Health again to see if the solar panel is showing as connected. If the device is showing as connected, please ensure you are getting 4 or more hours of direct sunlight to the solar panel during the day to allow a trickle charge to your device. You will also want to ensure that your device is not discharging more than it is charging, as you may have an excess amount of events that could be draining the battery on your device.

In the event you may not see the solar panel connected still, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Disconnecting & reconnecting the solar cord worked! Thanks.

1 Like

Same situation for me… and after unplugging/reconnecting, it lasted a few days but then went back to “not connected.” This has to be a Ring update that is causing this… but thus far I haven’t seen any fixes mentioned. Matt