Solar and Spotlight Cam Charge Issues

I have used the ring spotlight cam for many months and no issues… the solar always maintained good charge in the battery. However, suddenly this changed. The battery was using 20 to 40% of its power in a day. Also, the section in the app that shows how the device is powered no longer showed solar.

I contacted support over two days and spent 2 hours going through pointless checks. Eventually they suggested my device was faulty and replaced everything. Great!

The new device arrived, I fully charged the battery and reinstalled. But the same issue persists. No Solar is recognised, and no charge is being received.

It appears to be a software issue from a recent Ring update. At the same time my device started draining its battery I was also receiving ring push notifications saying my device is now plugged in, switch to wired mode. I have not accepted this, however, as soon as the solar panel is connected these push notifications start… and while I do not switch to wired mode the solar option in the app disappears and no charge is received and the battery drains very fast.

As I have the same issue with two devices it is definitely software.

Ring! What have you done. The system no longer works on Solar and from what I can see on this community and the web… thousands of people are reporting the same issue.

I have lots of good sunshine and have a doorbell that works just fine on Solar… it is just the spotlight cams that don’t seem to like the new software/ firmware update.

Interestingly… I read a post from someone else who showed a very detailed way to fix this, the crux was to select SpotLight Cam Solar in the drop down when setting up the device… but that device no longer exists as an option… it’s only hardwire or battery… again, this is a change from the recent software Ring update…

So, the current situation is that I have two devices and neither really works as a security device as the batteries won’t go beyond three days. I guess I could charge it every three days but that is not really the idea is it.

Be interested if anyone from Ring will respond with a solution that actually works. I would email this with screen shots and photos through to Ring but they dont want emails… just phone calls to the call centre. The people who answer the phones are friendly enough but dont actually understand the problem and I dont really have that many hours to spend on this either. It is funny isnt it. These huge organisations remove proper and effective support and replace it with a community… so we kinda self diagnose and help each other, meanwhile the organisations saves money from actually helping us in the first place. Weird world 'ey.

@user73612 I too suspect an issue from a recent software or firmware update. I have two Stick Up Cam Pro cameras, each powered by Ring 4W Solar Panels, and they had been charging fine until recently. In fact, the level was constantly topped off at 100%, even though, according to Ring’s website, there is supposed to be optimized battery charging for the Stick Up Cam Pro, so it would “not exceed a threshold of around 80 percent”. Well now I have the opposite problem, no charging at all.

1 Like

Hi @user73612. Thanks for sharing which troubleshooting steps you have already tried for this issue. I do want to clarify that the Ring Community is not a replacement for our support team. The Community is a public forum where neighbors can interact with each other and ask questions, and our moderation team can assist with general troubleshooting information. We have some information on solar panel concerns here, though it sounds like you have attempted most of the basic steps already.

Should an issue persist after general troubleshooting assistance is given, we recommend getting in touch with our support team directly to take a closer look at things on the back end. We don’t have access to any device information here on the Community, so we are more limited in how we can assist. You can give our support team a call at one of the numbers available here. You can also get in touch with our support team on Facebook @Ring.

Update: After doing further research, as far as not charging at all, the problem could be that it was too cold.

See Battery-Powered Ring Cameras and Cold Weather

That could actually be the problem i atm are having, living in Sweden we have quite cold climate in the winter time.
Will see if the junk begin to charge when its getting warmer.

Still have the issue that the lights coming on and off every 30 seconds or so when its set to turn on for motion (even i motion is not triggered)

1 Like

I am having this issue where the solar will stop charging. I have done some troubleshooting myself. I unplugged the solar panel and plugged it back in and rebooted the device. It will show that everything is working. The next day…no solar charge even though one of my batteries is low. I have tried this over several days and got the same result. I live in FL so it can’t be the cold. I believe it is software-related where the solar panel is not triggering.

So I solved my issue. Looks like I had a defective solar panel. I ordered a new one and it charges the batteries without my intervention.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.