Snapshot feature disappeared

I had the snapshot feature enabled and working on a doorbell ver 2 and recently noticed it had quit capturing the snapshots (not sure when it quit exactly) and when I went to settings the option was no longer there. Is there anything I can do to get this functionality back? I assume it’s something Ring did on their end as I haven’t changed any settings on this doorbell since it had been working and since the option under the video settings has disappeared as well it just seems like a ring side issue. Any ideas on how to get it back would be appreciated. The video recording and everything else is working correctly. Thank you

Hi

I also had the Snapshot feature, but it disappeared a few days ago, I was on the phone with support but they couldn’t solve it, they are still working on it and was supposed to revert back when they found a solution.

Really miss this feature

Anders

Hi neighbors! Thanks for bringing this to our attention. Looks like you got a sneak peek of our new Snapshot Capture. Snapshot Capture is currently available on the following devices purchased on or after October 23, 2019, however, we are excited to launch this for all neighbors in the near future. Thank you for your patience while we work to perfect this new feature!

This problem was NOT solved, it is an existing problem. Ring, please do not tag this as a solved problem. My timeline/snapshot also disappeared from my timeline with no apparent solution from Ring.

6 Likes

I notice that it now says in your article you linked to about snapshot that it is available on all ring products so how do I get it back working? I really liked the feature especially since my doorbell misses most of the action until people are leaving. At least this way I have the off chance that a snapshot pic would be taken when someone had started down the sidewalk or at the door instead of pulling away before the doorbell captured a image.

Thank you in advance for your prompt attention to this matter.

I installed my ring doorbell pro about 20 days ago and it too has stopped capturing snapshots? At least I now know this is a problem and it has not been resolved. Anyone have the same issue and was able to resolve since ring isn’t helping?

I installed a floodlight can which is also not acquiring snapshots. I have called ring customer service numerous times and no one has any information. Any insight?

2 Likes

I don’t even have the option to enable it under Video Settings where all instructions say. But there is an option called Snapshot Capture under Device Settings. This is enabled but doesn’t work that I can see. This is on my video doorbell pro.

Is it obvious that there is a snapshot in the timeline if it has worked? Rings instructions for this as so typically half-assed.

Thanks

Is your Pro doorbell firmware up to date? Or does it have a number?

Hi. It’s firmware is 2.2.00097. It’s a Video Doorbell Pro. Also running the latest iOS version of the app cheers

Ok, I was on that build before the snapshot began to work. It took about 4 to 5 weeks before it just updated overnight on its own. Now it works perfectly. So, hang in there. It will update but it takes a little time. I tried to force it but it never worked. It’s rolling out slowly so it should come soon for you too.

2 Likes

Thanks. So you actually do have the option for Snapshot in your Video Settings, where as I don’t at the moment?

Correct. I could see the feature but it did not work until the firmware was updated. Once it reads up to date only, then the feature will work completely for you. Took 4 to 5 weeks from when I bought it to update.

Only bought my 1st camera in Jan and snapshot was there but this has now disappeared. Bought another camera a month ago and it’s in that one. This is absolutely ridiculous Ring seem to solve one problem then something else happens ?

not solved, woke up today, all 4 devices not sending snapshots, phone, twitter, online, zero help

How is yours today? It is still not working today on mine just wondering if anyone else was still having issues?

My rich notifications(little pic on the notification pop up on my phone) suddenly stopped working yesterday, on both my ring doorbell and my stick up cam.

My rich notifications pic previews has stopped working and it was so handy

Well glad it is not me because mine has also stopped working over the few days and nothing seems to fix it, and seeing quite a few people online are having the same issues so hopefully a fix is found soon as this featues is just to good to lose.

Hello neighbors, if you are currently experiencing the concern of your Rich Notifications not working for your battery devices, it is because this service is currently offline. Check out our Status Page for up to date information on this concern. Our team is working to resolve the issue to restore the service as soon as possible. Thank you for your patience!