Snapshot download failed on Ring Doorbell Pro

I have a Ring Doorbell Pro that will not save snapshots. I am able to save videos. I am using the newest Android version of the Ring app version 3.31.0 on my Samsung Galaxy S20 Ultra and Samsung Tab 7+. Both are listed as Authorized Client Devices in the Control Center. I have activated the Snapshot feature in the device settings. The firmware says that it is up to date though I don’t know the firmware version. My RSSI varies from 60-64.
I have searched for a solution, but have not had any luck finding one.
Thanks in advance for your help in solving this problem.

Hi @majbuzz. I would try uninstalling the Ring app, rebooting your phone, then reinstalling the Ring App. Once that is complete, try to download your snapshots. If you are still unable to download them, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Thanks for your response. I will try the next chance that I have.

1 Like

I have the same problem. I tried uninstall the app. Rebooted my device and reinstalling the app but this did not fix the problem. However, the snapshot download works on my daughter’s iPhone, but not on my wife’s Android too. It seems like the Android app has problem. I am also able to download video clip. Just not snapshot.

Hi @BigDaddy2000! It sounds like you’ve tested and narrowed this down as only impacting android devices. I recommend checking for any android apps that might conflict with the Ring app. Please also ensure there is not a vpn enabled. I hope this helps! :slight_smile:

Thanks. I’ve had to put it on the back burner for a time. I will look into it and if I fix it, I’ll post the fix here.

Mike

Hi. I tried several things to get my snapshots to download with no luck, so I quit trying for awhile. Today I decided to give it a shot and it works! It was probably a bug that got fixed in an update. Thanks again for trying to help me out.