Snapshot Capture not working Ring Doorbell Pro"

As title says i had the featre when i had a bought a refurbished model had problems with the reset button where i couldent re boot sent me new unit, seems firmware is updated dont know what old one was now no snapshot , ive re installed several times and re booted and nothing ???

Hey @speedydog5! If you are still not seeing the Snapshot Capture feature in your timeline view, check out our help center article about activating this feature. You’ll also find some tips and tricks on optimizing how snapshots are taken. I hope this helps! :slight_smile:

none of that worked still waiting for a firmware update that still has not happened from your supposedly advance tech team, replaced doorbell twice and still same problem its unbelivable that for the cost of your units and amont you still cant get fixed totally unacceptable

1 Like

I have the exact same issue and tech also told me the exact same thing still no resolve!

1 Like

How long has the pro been in service so far? Took mine 4 to 5 weeks to get updated firmware. Now it works fine

Has this issue been resolved for everyone? It still does not work for me no matter what I do. It was working just fine a month or so ago.