Slow Connection to Devices

What is up with the app lately? I have a doorbell and two stickup cameras. One of the three will have a black screen for the preview. None of them connect right away. Someone rang my doorbell the other day, except it rang three minutes after they left the porch. I could not determine the time for a while because I could not get to live view. In the past, my stickup cameras were instantly connected. Not any longer.

I have made no changes to my Wi-Fi mesh network. Signal strength per the health tab is strong. My Wi-Fi Signal Strength app shows 95% at each device. My Chime is less than 12 feet from the front door and sits in the middle of a triangle of the cameras.

This issue is either the app issue or the servers. Are you placing too many people on one server and overloading its ability to communicate?

I am a tech-savvy individual. I have restarted my Wi-Fi router, disconnected the power from my devices and restarted them. I added a new mesh node closer to the stickup cameras despite the 95% signal strength on 2.4Ghz and 5Ghz. I am the only system on the Wi-Fi channel, so there is no interference.

@Ring, fix whatever is wrong. Update the software so we can see all cameras simultaneously. If someone were to go from my porch into the backyard, I could not bring the cameras online fast enough to know where to “greet” them. This is the reason I spent the money on the products and pay for the monthly plan.

I clear the cache daily. I have an app for that. It is not the phone. It was this way a few months after installing it, but the next upgrade fixed it. Now it is back to the same stuff.

As for “pointing to it,” sure, maybe @Ring will send someone over so they can see me point. The dig about tech-savvy and the VCR was unnecessary and unhelpful. If you put people down like that, you should not respond to posts.

How do you know I have not reached out to tech support? You do not. When I searched topics, I found more posts than I cared to read. However, I read random samplings of people having the same issues.

Although they call it a cloud server, it is still a piece of hardware with physical components that have limitations. Assign too many accounts to one server, and it moves slowly. With duplex communications and overloaded servers, the throughput can get clogged.

I have been working on networked computers since the mid-1980s. I could listen to the screech on a dial up modem and tell you the connection speed. With a 1 Gbps broadband connection, there should be no noticeable delay when I want to connect to a device. My Wi-Fi speeds are much faster than my cable speed. A connection to another device on my network should not take more than a few milliseconds. Since Ring routes that connection through their servers, I suspect that is where the problem is. Someone in another country that reads troubleshooting guides from flash cards and concludes that they do not know what else “to be doing to be assisting you” is not tech support.

After posting my original topic, I tried to connect to live video on all three devices. All three had the spinning circle for over three minutes. After my third attempt on each device, there is an issue outside of my network. I can connect to my printer, laptop, other Wi-Fi security cameras, and my other devices instantly. Pinging the IP address of each device is about what I expect. The only Ring device I can gain an immediate connection to is the Chime. Connecting to the Chime does not route through Ring servers like the cameras do.

My app has been getting buggier and buggier lately as well. I just updated a post that I made a few years ago about “Mode Change Failed” and dashboard not loading etc. Those issues have returned for me. I have cleared app cache, uninstalled and re-installed app etc. I power cycle model and router on regular basis and recently upgraded router. Are you also experiencing mode and dashboard issues?

Also, agree that the Ring Doorbell response has gotten so slow that it is not usable for answering the door.