Sharing ring doorbell problem

I’ve been trying to share gen2 doorbell to family for two days now. I’ve shared and authorized the bell, they have the email and follow links to create an account, open app and there is nothing in location as shared. I’ve tried deleting the invites and resending and delete there app and reload but nothing. Tried to invite again this morning after deleting the invited users and when they follow the ‘manage access’ link in the email it’s just saying ‘Unable to authorize. Please try later.’ for the last 3 hours. Any help please.

Hi there, @Mattb1! This is odd to hear, as it sounds like you are doing everything correctly. This help center article has the steps and tips needed to get shared users working. Keep in mind, it takes a few moments before the Shared Users device shows up in the shared users account, and up to 15 minutes when sharing an Alarm system. Although you mentioned doing so, please have the shared user check other locations in their Ring app, to see if the device is appearing under that section.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Did this ever get resolved? I’m having the exact same issue!

Hi if this wasn’t resolved. I had the same issue for about 10 minutes.

Open the email that that contains the share button or manage access.

Hold down on the button and copy the link address then paste into a new browser. Worked straight away for me.

For some reason it didn’t like the chrome browser and always gave and authorisation issue.

Hope this helps.

1 Like