Shared user cannot add or access lock

As an owner, I linked a lock(Schlage Encode Smart Wi-Fi Deadbolt BE489WB) using the android app and Amazon key. That worked flawlessly, and now I can control the lock from the live view.

At the same time, my shared users do not seem to be able to replicate my results or to see the lock I added. When they try to link the lock to their accounts, it says “lock not found” and this is false as they also have shared access to the lock in Amazon Key and can control it as well.

The only difference between them and my access is that I am the owner for both the lock and the ring devices.

I tried adding multiple screenshots, but as a new user I can only add one.

Read access view to the lock

Hi @ring1010. Thanks for sharing details on what you’re seeing on your end and attaching a few screenshots. I looked into this, and at this time, locks set up with the Key by Amazon App cannot be shared with your Shared Users in the Ring App. You can read more information about what is available with the Key By Amazon App and the locks that work with it in our Help Center Article here. I hope this helps clear things up, and we’ll be sure to pass the feedback along regarding sharing the locks to the appropriate team.