Security screw is stuck

One of my security screws on my ring doorbell is stuck, so I can’t remove and charge the device. I’ve tried spraying some WD40 on there, but the bit just starts to break off/strip. Any other ways to get this out?

Seems this is common problem - wish I read about before I bought it (1st gen Ring) - I just had the same problem - I had to dremel a slot to get the screws out and then used a flat head screw driver. – I did this AFTER i cut the 4 screws off the frame – since I was getting ready to throw the thing away – They sell a replacement kit on Amazon… Poor Design

2 Likes

Nothing from Ring support?

1 Like

Call customer support. This is a peer to peer forum mainly. The agents here will help for basic issues but will refer you to the main customer support.

I have the screw driver that came with my ring doorbell. Got the 1 screw out just fine, the other one just spins and spins. Tried to get a pair of plyers on it, but it’s so small I can’t all I need to do is to get to the back of it to change my wifi. Been working on it for a full day. Need help

1 Like

Hi @turtlehopper81! Excellent call trying the pliers to remove that screw. If it is too small to grab with pliers, try using a rubber band to both pull and turn the screw. If this concern persists, please reach out to our support team for more solutions, or check back here for any advice from other neighbors. :slight_smile:

1 Like

How about manufacturing screws that can withstand being screwed out?? That would be a good solution. This is a security device. Having shoddy screws is just so disappointing, if not ridiculous.

3 Likes

Purchased RING… It was delivered on 4/21/20, installed on 4/29/20. Installation was quick and easy. Received notification of low battery on 5/7/20. One of the security screws will not come out! It only turns.
I’ve tried using a rubber band, exacto knife, and pliers (no grip),
I’ve been back-and-forth with this thing since 5/7/20, 5/8/20, and AGAIN at 2:30am on 5/9/20.
I guess it’s making up for the easy installation. .Need an solution from Customer
Support ASAP.

1 Like

I own the Ring 1st generation. I now am experiencing the exact same problem. I have even tried using a precision screwdriver set to remove the screws. Neither one will budge. The design is flawed, and Ring (now owned by Amazon) will probably not do a thing for the customers in this position. I will not be renewing my Ring subcription because all I have at this point is a fancy doorbell that just rings.

I have a 1st Generation Ring Doorbell, and I am now having the exact same problem everyone above has mentioned. One of the security screws comes out just fine, but the other screw just keeps spinning and spinning. I have even tried some WD-40 at the base of the screw in hopes that it will loosen it up. It’s nearly impossible to to put anything at the base of the screw to try and hold it while unscrewing. It would be nice if Ring could acknowledge this issue, try to recreate the problem on a test unit, then come up with some solution to fix it. I don’t need it to be a free fix or a replacement device. I would just settle for some “tips” to make removing the screw easier.

Same problem here on a first gen Ring that is only a few months old. 1st screw went after about a month. 2nd one has lasted a bit longer but as of yesterday now just spins. Clearly a design flaw based on the above comments.

3 Likes

i have just had the same problem. heres what you do. once you get it off [the little arm didnt break much] take a small screwdriver and apply pressure to the other end of the screw while loosening it. it will come out and can still hold your ring in place.

1 Like

how do I get it out?

I’m having the same problem! Now my doorbell is barely hanging on to the mount. I’m pretty upset considering I haven’t even had it a year and I paid over $100 for the thing.

Same problem here, I was able to remove the battery. Now the battery is without the screw. Is any warranty for the battery or I just need to use it without the security screw?

Same problem here, ive been fine with unscrewing and replace the battery until now I can’t seem to unscrew it to charge the battery ? Can anyone help me how I remove the screw and definitely feel like ring bell should try and change how its been screwed as mine looks like someone try to unscrew it maybe stripped the screw from trying without the right tool … it just seems very odd to me

Shocking from RING!!! It appears this is a common fault after I have just had a half an hour convo with them and they insisted I was the only one. To then be told they will do nothing about it as it’s out of warranty. The issue is the screw has fused to the gold thread that lives inside the device which makes it impossible to remove without force and then means you can no longer screw your device back on! If this is a known fault they should be replaced by RING!!!

1 Like

Shocking! I’ve had exactly the same issue. Over an hour on phone to support who said it was out of warranty and I could buy a new one. I don’t want to spend another £120 I want to get this one off and charge it.
RING please can you contact me in regards to a replacement as this is clearly an ongoing issue with many users!!!

If your security screws ever gets wedged/stuck. Use a power drill in reverse on high speed while pushing down hard

Don’t do this. I did, and the screws ended up inside the Ring Doorbell