Secondary user can't update address/neighborhood in Neighbor app

Hey there! We recently moved and I’m having an issue with the Ring Neighbors app/feature.

My husband is the Primary account holder and has the address updated there; when he opens the Neighbors app it shows the correct address and alerts/posts. However, mine still shows the former address, so I can only see posts related to where we previously lived. I can only change the name of the neighborhood (meaning what it shows up as for me, so not truly changing it), but cannot edit the address.

I have tried uninstalling and reinstalling, and I’ve given it over a week in case it needed time to update, along with reinstalling a second time.

I searched for a resolution, but only found suggestions of doing what I’ve already done. Has anyone been able to remedy this issue themselves in another manner?

Please remember: If you are looking at the edit options as a Primary account holder, I do not have the same options available to you. No issues on the Primary side!

Thank you kindly,
N.B.

Hey @Doom. Thank you for detailing out your experience here! I’m happy to help further with this. When you go into your Ring app > Main Menu > Neighbors, and you see your old location name at the top, can you tap on this and have another location option to pick from, hopefully one with the same name as the new Location as your husband sees it in his app? If you see another location, tap on that one and it should bring you to the same area your husband is seeing. :slight_smile:

@chelsea_ring

When I go to Ring > Menu > Neighbors, clicking the old neighborhood name does nothing. I can press the Settings cog/gear to the right of it, which shows the old address (that I also cannot click or edit), Neighborhood Name (I can only edit how the name of it appears to me, not the neighborhood location). Options as a secondary user seem to lack the ability you mentioned.

Elgin is the correct one, Chicago/Montclare is the old one. First pic is opening Ring for me, it says Elgin which is correct. Same with second pic. Third pic is when I go into Neighbors, it shows Montclare which is wrong and I cannot click Montclare. Fourth pic is when I click the Settings gear to the right of Montclare, which shows the old address in Chicago (I also can’t click that).

On my husband’s side, everything says Elgin. No trace of Chicago/Montclare.

Hey @Doom. Thank you for much for getting back to me and detailing that out for me! We do have a concern that our team is looking into with an old location still showing up in the Neighbors app, and it seems like you’re running into exactly that. While our teams works on a way to get this addressed, I have a work around for you to do in your app! We are going to pretend we are creating a new location/setting up a new device, but will not finish this setup, and this should give you an additional neighborhood to pick from. I’ll outline these steps for you, and my apologises in advance as this may seem like a lot:

  • Go into your Ring app and open the Main Menu, and then select Set Up A Device
  • Select Doorbells, Scan Code, and tap the question mark at the bottom right
  • Tap on “I’ve tried scanning, and it’s not working”
  • Select Ring Video Doorbell and then Help Me Find PIN Code
  • Tap on No PIN Code and then Create a New Location, and then Create New Location again to confirm
  • From here, type in the address exactly how your husband did on his phone when changing the address and then hit continue
  • Confirm this address and then hit cancel at the top right of the next page
  • It’ll ask if you’re sure, and we are, so go ahead and tap on YES
  • From here, go back into your Shared location where you see the devices, and navigate to the Dashboard

From the Dashboard, tap on Nearby Incidents and then at the top left if it says Montclare, can you select that and then toggle to one that should say Elgin? Let me know if this works! :slight_smile:

That was a good work-around, but it has now been 4 months since this thread started. Are there any changes to this, as my wife is experiencing the exact same issue.

I’m having the same issue as a secondary user. What’s the progress on a fix?!

Hey neighbors! If the above mentioned suggestions haven’t worked for you and you are still experiencing this concern, you would be best served by reaching out to our support team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

We recently moved and I’m having the same issue. The covid excuse is annoying and does nothing to resolve. Thanks.

1 Like

Hello, I know this thread is from 1.5yrs ago but this is still an existing issue in the Ring app that I am currently experiencing as a secondary user. Can someone please detail the current work around for how to resolve so I can view the correct Neighbors community? I tried the resolution in the original post but it no longer appears that following this set of steps is possible. Would love to resolve ASAP as we’ve had an incident at 4am tonight with a man checking doors on our cameras, so I would like to communicate with our neighbors about this rather immediately.

1 Like

Useless as always. Useless as always.