Schlage Lock not connecting with Ring Alarm hub

I just installed my Ring Alarm system this weekend, and so far the only issue is that I can’t get my Z-wave Schlage log to connect. Right now it is connect to my Samsung hub with out a issue.

I have my phone looking for the lock for through the Ring App, once it starts searching I hit the Schlage logo, enter my 6 digit code, and hit 0. I get the green check for a second and then about 30 seconds later I get the red X. I am just not sure what I am doing wrong.

Do I need to have the Ring hub right by the door to do this? The hub is right now about 10 feet away. Thanks for any help.

Thank you

Lock I have: The board is green for Zwave

Hey @veener79 ! When connecting the locks, it can help to have the Base Station very close for pairing. From your post, it does sound like the lock is still paired to your smart hub. Keep in mind, the lock will not connect to more than one hub at a time. Please follow the removal steps for your Samsung Hub and the Schlage lock.

If you feel the Schlage Lock has added to your Alarm in an errored state, the following steps will walk you through removing the device for a fresh setup:

  • Tap the menu button > devices > Alarm Base Station > Gear Cog (top right corner) > Advanced options > Z wave > Remove a Z Wave device.

  • When the app says “listening for device to remove”, put the lock into ‘discovery mode’ by pressing the Schlage button, entering your programming code, then pressing 0.

Let us know if that helps!


Hi Marley,

I found what the issue was. Since my lock was all ready paired with Samsung Hub I had to umpair it. I guess it can only be paried to one item at a time. All fixed now. :slight_smile:

1 Like

I tried those steps in the Ring hub and worked like champ. Wish I knew this earlier. I have been dealing with trying to get this paired for months in my FE599.


1 Like